WHQL wake-up test (errata 772) for LAN devices

Does anyone know why the wakedevs provided with HCT 11.2, 12.0, and 12.1
fails, as per errata 772? I have run it on one driver, and had it pass,
and then the next rev the test failed. I was able to submit subject to
the errata, but if there’s a hoop I can jump through to get a
clean-test, I would like to do it.

All I know is, when I run wakedevs /L from the command line, with the
failing rev of the driver, the IP address is With the passing
rev, the IP address is correct. Ipconfig shows the correct IP address
in both cases. I haven’t yet had chance to start with the “good”
driver, and add change by change until it goes bad, but with the “good”
driver, if I put two NICs in the system, one has the correct IP address,
and one had the IP address I just can’t see how the IP address
relates to the NIC miniport. When I run the wakedevs manually with the
“good” NIC, it works. Whenever I run it with a driver, either
with the “good” rev of the driver, or the bad rev, the test fails.

One other thing I know is that in the failing scenario, the wakesrv does
not ping the system under test. I presume it cannot, since it does not
have the correct IP address.

I also have not seen any LOMs which fail this test, which leads me to
believe there must be some “trick” to force the IP binding into a state
whereby wakedevs accepts the IP address as being attached to the NIC?