Re: Property Page DLL in registry won't change. When does one change the .inf class GUID?

When you add a class dll, it gets appended to the end of those which
preceded it (many of them inbox). When you reinstall with the new INF, you
should be seeing your “DevPropSheet.dll” getting appended as well. However,
when SeupAPI parses these definitions to find the dll to utilize, it appears
to do so in a left to right fashion. Thus, it will find your old
“TestDevPropSheet.dll” before your new one.

To fix, uninstall your driver, search registry for “TestDevPropSheet.dll”
and edit the string variable to remove ONLY that reference from the string,
leaving those definitions preceding it still there.

“Michael Wade” wrote in message
> I see these heavy duty threads going on about interrupt priority and
> filters and I feel like a little kid crying “Let me play! Let me
> play! You never let me play!”
> Be that as it may. I am trying to get a property page up and going and I
> thought that I did. But I can’t seem to get rid of my test dll for the
> property page provider. I have a line in my .inf file that reads:
> HKR,EnumPropPages32,“DevPropSheet.dll,DevicePropPageProvider”
> It used to read:
> HKR,EnumPropPages32,“TestDevPropSheet.dll,DevicePropPageProvider”
> However, when I install it, my old “TestDevPropSheet.dll” seems to always
> get loaded. I have uninstalled the driver, deleted the corresponding
> oem*.inf files and everything else I could think of. But it still wants
> grab that test dll. I then looked in the registry for it, and it’s in
> there under HKLM/SYSTEM/CurrentControlSet/(CLASSGUID). But I don’t know
> why it’s not getting overwritten when I load the device driver again using
> the .inf file with the DevPropSheet.dll (without the Test). The GUID
> corresponds to that in the [Version] section key = ClassGUID. Which
> up another question that is probably at the root. When should one change
> the Class GUID? And where does one find information about that GUID? I
> tried the Win2k DDK, but if it’s there then I’m not finding it.
> Thanks for any help,
> Michael