RE:[ntdev] Cannot debug Windows Server 2008 kernel

First, the basics.

  • are you sure that you are using a null modem cable and not a straight thru or other? To make sure, try connecting both machines with hyperterminal.

Also, make sure that you have done at least one of the following:

  • started windbg with -b on the command line

  • started windbg with -d on the command line and then rebooted

  • set halbreakpoint to on with bcdedit on the target

  • pressed “ctrl-c” in windbg once the target is up and running (earlier will work as well, but too early in the boot process will not, so just wait until it is showing you a logon screen

  • taken “Break” from the “Debug” menu in windbg, also when the target is up and running

If you have done at least one of those, and windbg still doesn’t break in, then are you using WinDbg 6.7.5.0 and does the target halt, but windbg doesn’t break in? If so, then make sure you aren’t using -b, -d or halbreakpoint. 6.7.5.0 (and maybe 6.7.5.1; I don’t know) has a known issue with these settings.

If it’s neither of these three scenarios, you’re going to have to give us some more information.

Good luck,

mm