Property page for KS pin in graphedit?


I was able to get a property page to display in graph edit for a filter.
However, I tried to add pin properties and haven’t been able to get a
property page to display in graph edit for a pin. I followed the same
procedure as with the filter, being careful to use a different GUID for the
KSPROPERTYSET when creating the automation table. I included the automation
table on the second line of the KSPIN_DISCRIPTOR_EX. I used the new GUID in
the CFactoryTemplate of my com interface. I added a property set to property
page mapping in the registry under

Nothing I seem to do will make the pin properties show. Looking at regedit,
the registry entries created when running REGSVR32 for the pin plugin follow
the same pattern as with my filter. Looking at the object in OLE/COM Object
viewer also follows the same pattern.

Where I’m stuck is how to debug this further? The KS documentation is
extremely lacking. In Linux, I would just look at the source code, but
that’s obviously not an option here. I looked through the Platform SDK
documentation but only found property pages for a filter. The guy originally
working on our driver left for another company, so I’m left to figure this
one out.

Anyone out there have any suggestions or a pointer to some example code with
a property page for a pin? Better yet, has anyone ever tried to display
properties for a pin in graphedit?