Problem starting IddSampleDriver


Like many others before I am trying to get IddSampleDriver running on Server 2019 (1809). Although I am able to build and install it successfully I see errors when I enable it from device manager.
Looking for pointers from folks who have managed to get this sample to run successfully.

Things I have tried so far:

  • Enabled Verbose=On and Verifier using WDF Test Features Control Panel
  • Set ‘IddCxDebugCtrl’ registry key to 7F
  • Enabled tracing using: ‘logman create trace IddCx -o IddCx.etl -ets -ow -mode sequential -p {D92BCB52-FA78-406F-A9A5-2037509FADEA} 0x5 0x5’
  • Attached to WdfHost.exe using debugger and run ‘!wdflogdump IddCx’ and ‘!wdflogdump IddSampleDriver’
  • Set breakpoint on IddSampleDriver.exe!DllMain. I can single step through that however in the sample it doesn’t do anything.
  • I am seeing that the DriverEntry is not being called. verified by setting a breakpoint
  • I am seeing that the ‘iddcx!IddCxLibraryBindClient’ is throwing an exception (ex code: e06d7363 ) but I am unable to see the exception message or the object. I can share the windbg analyze output.

The error I see in the event logs is:

Device SWD\IddSampleDriver\IddSampleDriver had a problem starting.
Driver Name: oem96.inf
Class Guid: {4d36e968-e325-11ce-bfc1-08002be10318}
Service: WUDFRd
Lower Filters:
Upper Filters: IndirectKmd
Problem: 0x1F
Problem Status: 0xC0000001

Log entries in IddCx: There are 3 log entries
— start of log —
1: FxIFRStart - FxIFR logging started
2: FxInitialize - Initialize globals for SOFTWARE\Microsoft\Windows NT\CurrentVersion\WUDF\Services\IddCx0102
3: FxPoolInitialize - Initializing Pool 0x000002258D057538, Tracking 1
---- end of log ----


The ASCII characters in 0xe06d7363 are “msc”, and signal that a C++ exception was thrown. You should be able to enable C++ exception trapping in windbg to catch this. “sxe eh” will turn that on.


I was able to catch the exception and decode the args using
It’s throwing ’ “.?AVStatusException@@” from iddcx!IddCxLibraryBindClient’

Checking if has anything to do with AV runtime scans or controlled folder access.

I am not able to find any information on this exception. Still fails with the same error on Wudfrd.

Using latest Windows Server 2019 version (2004) worked for me. thanks for help.