NDIS65 test for PM requirements and Generic miniport requirements.

Hi All,

I am trying to get this test case to executed for a SDIO based wireless card. While executing this test case the test suite tries to " Attach all OS filter drivers"

This step fails with following error:

  • Instance ID: SD\VID_0271&PID_0701\5&13199BF9&0&0
    PnpManager::DoPropertyChange: Failed either SetupDiCallClassInstaller or SetupDiSetClassInstallParams. NT_STATUS (0xE000020B)
    PnpManager::StartDriver: Driver enable failed NT_STATUS (0xE000020B)
    WLanAdapter::AttachOSFilters: Unable to reenable miniport after attaching filter NT_STATUS (0xE000020B)

I can see that the driver was unloaded while this step was being tried out. I checked setupapi.h and the error seems to be

At this point i am unsure where the error could be. INF or elsewhere?.

Any help is welcome.


> At this point i am unsure where the error could be. INF or elsewhere?.

Is this the same driver as in your other question, for device SD\VID_0271&PID_0701 ?

The installation problem should be fixed before running ndistest.
From provided details, it’s hard to tell why the installation stops and the driver gets unloaded. It may be the INF or something in the characteristics passed to NDIS. Are you sure that MniportInitialize is not called?

– pa

Hi Pavel,

Thanks for replying. The driver i am working with is based on WDI model (newer one for WiFi drivers) so it does not have MiniportInitialize. This is replaced by AllocateAdapterHandler. I can see both using breakpoints and prints that this function is not called.

Yes the other query is also for the same device and driver. I am not sure if somehow both are related.

I probably didn’t come across this issue or didn’t look enough during development, but it is creating issues while running HLK.

I have also posted the INF if you’d like to take a look.



The bus type in the INF is 1 (NdisInterfaceIsa). Why? Does this really work with SDIO?

– pa

Hi Pavel,

Thanks for pointing this out. I tried changing this to 0 - internal once and didn’t see any change in behavior. Tried using 15 - PNPBus and didn’t see any difference either.

I just moved the driver over to a different system and it seems to work on that, not sure if things are platform related.