Issues with the callout driver initialization

Hi all!

We’ve got a WFP callout driver that was implemented more than a year ago and works perfect for us. But some time ago we had got a bug report from a user who tried to install our application (callout driver and a system service that works with this driver) on a Google Cloud Server with the Windows 2012 onboard. We tried to reproduce the issue and confirmed that the issue persists.

Here are some technical details:

  1. Callout driver registers several callouts on the following layers: inbound and outbound transport v4/v6, datagram v4/v6, ale flow established v4/v6.
  2. System service adds the callouts by calling FwpmCalloutAdd0() function.

All this works fine until we try to use it on Google Cloud Server instance. The investigation of the problem showed that when the FwpmCalloutAdd0() for FWPM_LAYER_ALE_FLOW_ESTABLISHED_V4 never returns on the system service side. There are no errors or something. This call just freezes. And this happens on the Google Server instance only.

Maybe Google blocks this somehow? This is really weird.

Any help is appreciated!


> Maybe Google blocks this somehow? This is really weird.

…or maybe Google installs yet another filter which has an interop with yours.

Maxim S. Shatskih
Microsoft MVP on File System And Storage


I also faced the same issue.
Check out this.It helped me.

This may be issue with vmware vmxnet3 nic driver!msg/gce-discussion/BwdYQSxdE14/46D5nzPhFAAJ

Thank you guys for replies!

The link provided by Ashish was really helpful and allowed us to fix the issue.
So the problem resolved.