Intel 82* chipset drivers upset Win2K checked kernel

I’ve just spent half a day chasing this down and wanted to see if the net
wisdom has a pointer.

I took Peter V.'s suggestion to use a checked HAL/Kernel to test my code.
So, I looked up the proper HAL and Kernel code to put in place (thank you
OSR!), set up the boot.ini and ran. It dies a horrible death
(KMODE_EXCEPTION_NOT_HANDLED). Weird thing is, my code isn’t in the system.
Not even installed yet.

My problem, I assume. I spend a couple of hours making sure I got the right
versions of HAL and NT*KRNL. No good.

Well, maybe it’s one of the “standard” drivers I loaded. After all, this is
a Ghost’ed “virgin” system, but it’s got all of the added drivers to make me
happy (nVidia, Intel, …). So, I format the partition, load Win2K Pro
straight from the MS disc, load in the checked HAL and kernel and voila,
everything is happy. I load the nVidia driver, and we’re still happy.

I load the Intel 82* chipset support. Then the system hangs while trying to
log in. If I run the “free” version of HAL/Kernel, everything wakes up

I’ve grabbed the most recent drivers (dated 6/7/2002) from the Intel site,
but still no joy. I have a sneaking suspicion that I’m actually looking at
two different failures (the BSOD and the hang), but I can’t get past one to
the other.

It’s a Dell system, but I think that’s irrelevant; using Dell’s install CD
gives the same symptom.

Anyone got a clue? Do I need to use a checked version of Intel’s drivers,
and if so how do I get them?

Stu Bell

Thanks to Steve and Jan for their comments.

Hook a debugger up. It’s probably just asserting. This
happens with a checked kernel, and it’s not such a bad thing.
With a debugger

Steve: Good point!! What was I expecting a checked build to do when it
failed, eh? I’ve hooked up the debugger, but I get no assertions - the
system’s spinning hard somewhere (in the storage stack, not surprisingly).
I’ll spill more information on my results a bit later – I have some WHQL
legal stuff to get started just now.

Wasn’t the Intel 82x chipset the one that had a memory
integrity problem under some conditions?


I think the first rule of debugging a driver should be “does
the system your doing testing on correctly run the OS and
certified drivers”? For me this means the checked build runs
fine and the system run the WHQL stress tests for days without

Jan: The hardware runs 98SE, Me, 2K (unchecked), 2KSP2 (unchecked), XP
Home, and XP Pro with no problems. Never a crash or hang that wasn’t
tracable to my driver work. I always run Driver Verifier on the NT-based
systems - no weirdness. I’d like to believe that the hardware is the issue,
but it works fine WITHOUT the Intel driver, but doesn’t WITH the Intel
driver? HMMMmm… I may be crazy, but I’d say it’s the driver.

Thanks for the responses – I’ll just keep hacking at it!

Stu Bell