DPInst ignoring /sa flag?

I’ve gotten an unsigned driver package put together for a software-only
legacy driver, and overall DPInst seems happy with it. I’m launching the
DPInst as part of my main installer—I can’t use DIFxApp or DIFxAPI
because the installer is 32-bit whereas the driver is 64-bit. The
command line is therefore “/q /lm /sa”.

Everything installs ok, but despite “/sa”, I still get an entry in
Add/Remove Programs. Below is the relevant excerpt from the DPInst log
file. Note that it acknowledges that it is supposed to suppress ARP
entries, but then goes ahead and adds one anyway at the end of the log.

I tried adding an xml file which also sets the suppress Add/Remove
Programs flag, but with no change in behavior.

What’s up with that?

INFO: ****************************************
INFO: 06/27/2006 11:28:48
INFO: Product Version
INFO: Version: 5.2.3790 Service Pack 1
INFO: Platform ID: 2 (NT)
INFO: Service Pack: 1.0
INFO: Suite: 0x0100, Product Type: 1
INFO: Architecture: AMD64.
INFO: Running under Local System Account
INFO: Interactive Windows Station
INFO: Command Line: ‘“C:\Program Files (x86)\Tactical
Software\SerialIP\driver\DPInst.exe” /q /sa /lm’
INFO: ****************************************
INFO: Current working directory: ‘C:\Program Files (x86)\Tactical
INFO: Running on path ‘C:\Program Files (x86)\Tactical
INFO: No valid ‘dpinst.xml’ file provided.
INFO: Install option set: Running in quiet mode. Suppressing Wizard and
OS popups.
INFO: Install option set: legacy mode on.
INFO: Install option set: Suppress Add or Remove Programs entries.
INFO: Found driver package: ‘C:\Program Files (x86)\Tactical
INFO: Preinstalling ‘c:\program files (x86)\tactical
software\serialip\driver\siserial.inf’ …
INFO: ENTER: DriverPackagePreinstallW
ERROR: Preinstall is not a supported operation for driver type 1
INFO: RETURN: DriverPackagePreinstallW (0x1)
INFO: ENTER: DriverPackageGetPathW
INFO: No driver store entry for c:\program files (x86)\tactical
software\serialip\driver\siserial.inf found. (Error code 0xE0000302.)
INFO: RETURN: DriverPackageGetPathW (0xE0000302)
INFO: ENTER: DriverPackageInstallW
INFO: Copied ‘siserial.inf’ to driver store…
INFO: Commiting queue…
INFO: Copied file: ‘c:\program files (x86)\tactical
software\serialip\driver\x64\siserial.sys’ ->

INFO: Installing INF file
of Type 1.
INFO: Installing legacy driver

INFO: Service ‘siserial’ was started
SUCCESS:Installation completed with code 0x0.
INFO: RETURN: DriverPackageInstallW (0x0)
INFO: ENTER: DriverPackageGetPathW
SUCCESS:Found driver store entry.
INFO: RETURN: DriverPackageGetPathW (0x0)
INFO: Successfull installation of ‘c:\program files (x86)\tactical
INFO: Created entry in Add or Remove Programs for

INFO: Returning with code 0x1
INFO: 06/27/2006 11:28:50