Cmdlet get-netadapterqos does not show remote or operational QOS parameters

I have a NDIS 6.3 and higher miniport that supports DCBX as specified by NDIS.

The NDIS miniport driver indicates remote and operational parameters (ETS, APP, PFC) using NdisMIndicateStatusEx with NDIS_STATUS_QOS_REMOTE_PARAMETERS_CHANGE or NDIS_STATUS_QOS_OPERATIONAL_PARAMETERS_CHANGE as appropriate.

My logs show that the miniport is setting the FLAGS field with the XXX_CHANGED properly set.

I have the same miniport loaded on our networking card on both ends of a back to back setup.

When I run the command on one, I get the full data (remote parameters and operational parameters). The remote matches what is local on the connected side.

When I run the same command on the other, there is no data whereas my logs show the miniport is indicating the data to NDIS correctly.

There are only 2 places where the remote and operational parameters are indicated.

a) After calling NdisMSetMiniportAttributes to advertise Hardware Qos and current QoS capabilities.

b) when the miniport receives a DCBX LLDP frame from the other side.

Any ideas on why the command does not show any data?.
How do I debug this?.

Any pointers are much appreciated,