Access Violations

I’m trying to debug some kernel drivers with WindBag/NT4,
and I sometimes get an “Access Violation”. However the
callstack, PC, and registers all point to user space. If I
do a “g” or a “gh” in Windbag, it just repeats, a “gn”
bluescreens with a “1E” (C00000005,UVA, 0, UVA).

I’m unclear about what this symptom means. Is it one of the many user
threads that are running that happened to die, and is unrelated to my
drivers? Did I manage to return to user space at IRQL 2 or something
(I tried that eariler, but fixed it and added assertions to catch similar bugs)?
Did I just jump off the end of the world in kernel space?

So how do I figure out what this means? If its some user
space thread that I don’t care about, how do I ignore it,
or at least figure out what thread it is? What exactly goes “gn” do?


Dave Harvey, System Software Solutions, Inc.
617-964-7039, FAX 208-361-9395,,
Creators of RedunDisks - Robust RAID 1 for embedded systems.

You are currently subscribed to ntdev as: $subst(‘Recip.EmailAddr’)
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)