Windows System Software -- Consulting, Training, Development -- Unique Expertise, Guaranteed Results

Before Posting...
Please check out the Community Guidelines in the Announcements and Administration Category.

More Info on Driver Writing and Debugging


The free OSR Learning Library has more than 50 articles on a wide variety of topics about writing and debugging device drivers and Minifilters. From introductory level to advanced. All the articles have been recently reviewed and updated, and are written using the clear and definitive style you've come to expect from OSR over the years.


Check out The OSR Learning Library at: https://www.osr.com/osr-learning-library/


Can't use windbg with Hyper-V on windows 10

vagrantvagrant Member Posts: 8
edited May 5 in WINDBG

I want to debug a driver, so I decided to use kernel debugging. Both the host and the VM are running windows 10.

I used the following commands on the VM to set things up:

  • bcdedit /debug on
  • bcdedit /dbgsettings SERIAL DEBUGPORT:1 BAUDRATE:19200

I then launched WinDbg with the following flags: -k com:pipe,port=\.\pipe\kmdpipe,resets=0,reconnect
but it doesn't really connect to the virtual machine,, all I get is the message:

Opened \.\pipe\kmdpipe
Kernel Debug Target Status: [no_debuggee]; Retries: [0] times in last [7] seconds.
Waiting to reconnect...

The funny thing is that I also a windows 7 machine on hyper-v and it works(although I have to restart the VM). What's happening here?

Comments

  • Tim_RobertsTim_Roberts Member - All Emails Posts: 13,403

    Did you set the VM settings to route COM1 to the named pipe kmdpipe?

    Tim Roberts, [email protected]
    Providenza & Boekelheide, Inc.

  • Sergey_PisarevSergey_Pisarev Member - All Emails Posts: 226

    You can use network debugging. No need to add com port(not sure if you even can add it to generation 2 vms). Plus network debugging very easy to establish with kdnet utility - located in the same directory as windbg.

  • vagrantvagrant Member Posts: 8
    edited May 5

    @Tim_Roberts said:
    Did you set the VM settings to route COM1 to the named pipe kmdpipe?

    Turns out the pipe was registered with a typo.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Upcoming OSR Seminars
OSR has suspended in-person seminars due to the Covid-19 outbreak. But, don't miss your training! Attend via the internet instead!
Kernel Debugging 30 Mar 2020 OSR Seminar Space
Developing Minifilters 15 Jun 2020 LIVE ONLINE
Writing WDF Drivers 22 June 2020 LIVE ONLINE
Internals & Software Drivers 28 Sept 2020 Dulles, VA