WinDbg Question on Win2k Pro

I want to stop on a breakpoint with a write access to I/O port 64.

I’m doing the following but I am not hitting the breakpoint on resets.

bw i4 64

Just making sure this is correct.

Thanks In Advance,
Joe

“Joe Moriarty” wrote in message
news:xxxxx@ntdev…
>
> I want to stop on a breakpoint with a write access to I/O port 64.
>
> I’m doing the following but I am not hitting the breakpoint on resets.
>
> bw i4 64
>
> Just making sure this is correct.
>
> Thanks In Advance,
> Joe

This is better asked and answered on Windbg. Are you saving your workspace
before you restart the target? If not, your BP is gone. If you are, are
you setting the initial BP or BP on first symbol load? The target needs to
break so Windbg can send it the right stuff to set up the BPs.

Additionally, I can’t find any reference to bw, but ba is break on access,
and that includes read, write, execute, and i/o, so it looks like your
syntax should be:

ba i4 0x64

The debugger doc for ba says:
Access
The type of access which will satisfy the breakpoint:
i (i/o)
(Windows XP and Windows .NET Server only, kernel-mode only, x86 only) Breaks
into the debugger when the I/O port at the specified Address is accessed.

So if you aren’t running XP or newer on an IA32 CPU, you won’t be able to
get it done. SoftICE can do that on older OS, I don’t know about IA64 or
X86-64

Hope this helps.

Phil

Philip D. Barila
Seagate Technology, LLC
(720) 684-1842

Also, the access to port 0x64 are 1 byte long, not 4, so

ba i1 0x64

might be more inline with what you are doing. You can also set the
appropriate bp in i8042prt to catch the write to the port (it is always
done in the same function).

d

-----Original Message-----
From: Phil Barila [mailto:xxxxx@Seagate.com]
Sent: Friday, November 01, 2002 8:56 AM
To: NT Developers Interest List
Subject: [ntdev] Re: WinDbg Question on Win2k Pro

“Joe Moriarty” wrote in message
news:xxxxx@ntdev…
>
> I want to stop on a breakpoint with a write access to I/O port 64.
>
> I’m doing the following but I am not hitting the breakpoint on resets.
>
> bw i4 64
>
> Just making sure this is correct.
>
> Thanks In Advance,
> Joe

This is better asked and answered on Windbg. Are you saving your
workspace
before you restart the target? If not, your BP is gone. If you are,
are
you setting the initial BP or BP on first symbol load? The target needs
to
break so Windbg can send it the right stuff to set up the BPs.

Additionally, I can’t find any reference to bw, but ba is break on
access,
and that includes read, write, execute, and i/o, so it looks like your
syntax should be:

ba i4 0x64

The debugger doc for ba says:
Access
The type of access which will satisfy the breakpoint:
i (i/o)
(Windows XP and Windows .NET Server only, kernel-mode only, x86 only)
Breaks
into the debugger when the I/O port at the specified Address is
accessed.

So if you aren’t running XP or newer on an IA32 CPU, you won’t be able
to
get it done. SoftICE can do that on older OS, I don’t know about IA64
or
X86-64

Hope this helps.

Phil

Philip D. Barila
Seagate Technology, LLC
(720) 684-1842


You are currently subscribed to ntdev as: xxxxx@windows.microsoft.com
To unsubscribe send a blank email to %%email.unsub%%

I am getting the following error when entering the breakpoint expression
below

kd> ba i1 0x64
I/O breakpoints not enabled
^ Syntax error in ‘ba i1 0x64’

Version of windbg is 4.0.0018.0

Any ideas?

Joe

-----Original Message-----
From: xxxxx@lists.osr.com
[mailto:xxxxx@lists.osr.com]On Behalf Of Doron Holan
Sent: Friday, November 01, 2002 12:53 PM
To: NT Developers Interest List
Subject: [ntdev] Re: WinDbg Question on Win2k Pro

Also, the access to port 0x64 are 1 byte long, not 4, so

ba i1 0x64

might be more inline with what you are doing. You can also set the
appropriate bp in i8042prt to catch the write to the port (it is always
done in the same function).

d

-----Original Message-----
From: Phil Barila [mailto:xxxxx@Seagate.com]
Sent: Friday, November 01, 2002 8:56 AM
To: NT Developers Interest List
Subject: [ntdev] Re: WinDbg Question on Win2k Pro

“Joe Moriarty” wrote in message
> news:xxxxx@ntdev…
> >
> > I want to stop on a breakpoint with a write access to I/O port 64.
> >
> > I’m doing the following but I am not hitting the breakpoint on resets.
> >
> > bw i4 64
> >
> > Just making sure this is correct.
> >
> > Thanks In Advance,
> > Joe
>
> This is better asked and answered on Windbg. Are you saving your
> workspace
> before you restart the target? If not, your BP is gone. If you are,
> are
> you setting the initial BP or BP on first symbol load? The target needs
> to
> break so Windbg can send it the right stuff to set up the BPs.
>
> Additionally, I can’t find any reference to bw, but ba is break on
> access,
> and that includes read, write, execute, and i/o, so it looks like your
> syntax should be:
>
> ba i4 0x64
>
> The debugger doc for ba says:
> Access
> The type of access which will satisfy the breakpoint:
> i (i/o)
> (Windows XP and Windows .NET Server only, kernel-mode only, x86 only)
> Breaks
> into the debugger when the I/O port at the specified Address is
> accessed.
>
> So if you aren’t running XP or newer on an IA32 CPU, you won’t be able
> to
> get it done. SoftICE can do that on older OS, I don’t know about IA64
> or
> X86-64
>
> Hope this helps.
>
> Phil
> –
> Philip D. Barila
> Seagate Technology, LLC
> (720) 684-1842
>
>
>
> —
> You are currently subscribed to ntdev as: xxxxx@windows.microsoft.com
> To unsubscribe send a blank email to %%email.unsub%%
>
>
> —
> You are currently subscribed to ntdev as: xxxxx@east.sun.com
> To unsubscribe send a blank email to %%email.unsub%%

Same error with version 6.0.17

Joe

-----Original Message-----
From: xxxxx@lists.osr.com
[mailto:xxxxx@lists.osr.com]On Behalf Of Joe Moriarty
Sent: Tuesday, November 05, 2002 2:19 PM
To: NT Developers Interest List
Subject: [ntdev] Re: WinDbg Question on Win2k Pro

I am getting the following error when entering the breakpoint expression
below

kd> ba i1 0x64
I/O breakpoints not enabled
^ Syntax error in ‘ba i1 0x64’

Version of windbg is 4.0.0018.0

Any ideas?

Joe

> -----Original Message-----
> From: xxxxx@lists.osr.com
> [mailto:xxxxx@lists.osr.com]On Behalf Of Doron Holan
> Sent: Friday, November 01, 2002 12:53 PM
> To: NT Developers Interest List
> Subject: [ntdev] Re: WinDbg Question on Win2k Pro
>
>
> Also, the access to port 0x64 are 1 byte long, not 4, so
>
> ba i1 0x64
>
> might be more inline with what you are doing. You can also set the
> appropriate bp in i8042prt to catch the write to the port (it is always
> done in the same function).
>
> d
>
> -----Original Message-----
> From: Phil Barila [mailto:xxxxx@Seagate.com]
> Sent: Friday, November 01, 2002 8:56 AM
> To: NT Developers Interest List
> Subject: [ntdev] Re: WinDbg Question on Win2k Pro
>
> “Joe Moriarty” wrote in message
> > news:xxxxx@ntdev…
> > >
> > > I want to stop on a breakpoint with a write access to I/O port 64.
> > >
> > > I’m doing the following but I am not hitting the breakpoint on resets.
> > >
> > > bw i4 64
> > >
> > > Just making sure this is correct.
> > >
> > > Thanks In Advance,
> > > Joe
> >
> > This is better asked and answered on Windbg. Are you saving your
> > workspace
> > before you restart the target? If not, your BP is gone. If you are,
> > are
> > you setting the initial BP or BP on first symbol load? The target needs
> > to
> > break so Windbg can send it the right stuff to set up the BPs.
> >
> > Additionally, I can’t find any reference to bw, but ba is break on
> > access,
> > and that includes read, write, execute, and i/o, so it looks like your
> > syntax should be:
> >
> > ba i4 0x64
> >
> > The debugger doc for ba says:
> > Access
> > The type of access which will satisfy the breakpoint:
> > i (i/o)
> > (Windows XP and Windows .NET Server only, kernel-mode only, x86 only)
> > Breaks
> > into the debugger when the I/O port at the specified Address is
> > accessed.
> >
> > So if you aren’t running XP or newer on an IA32 CPU, you won’t be able
> > to
> > get it done. SoftICE can do that on older OS, I don’t know about IA64
> > or
> > X86-64
> >
> > Hope this helps.
> >
> > Phil
> > –
> > Philip D. Barila
> > Seagate Technology, LLC
> > (720) 684-1842
> >
> >
> >
> > —
> > You are currently subscribed to ntdev as: xxxxx@windows.microsoft.com
> > To unsubscribe send a blank email to %%email.unsub%%
> >
> >
> > —
> > You are currently subscribed to ntdev as: xxxxx@east.sun.com
> > To unsubscribe send a blank email to %%email.unsub%%
>
>
>
> —
> You are currently subscribed to ntdev as: xxxxx@east.sun.com
> To unsubscribe send a blank email to %%email.unsub%%

Arghh!

Go immediately to http://www.microsoft.com/ddk/debugging/ and get the
latest version of windbg. The version you are running is pure shite.

===========================
Mark Roddy
Consultant, Microsoft DDK MVP
Hollis Technology Solutions
xxxxx@hollistech.com
www.hollistech.com
603-321-1032

-----Original Message-----
From: “Joe Moriarty”
To: “NT Developers Interest List”
Date: Tue, 5 Nov 2002 14:19:17 -0500
Subject: [ntdev] Re: WinDbg Question on Win2k Pro

> I am getting the following error when entering the breakpoint
> expression
> below
>
> kd> ba i1 0x64
> I/O breakpoints not enabled
> ^ Syntax error in ‘ba i1 0x64’
>
> Version of windbg is 4.0.0018.0
>
> Any ideas?
>
> Joe
>
> > -----Original Message-----
> > From: xxxxx@lists.osr.com
> > [mailto:xxxxx@lists.osr.com]On Behalf Of Doron Holan
> > Sent: Friday, November 01, 2002 12:53 PM
> > To: NT Developers Interest List
> > Subject: [ntdev] Re: WinDbg Question on Win2k Pro
> >
> >
> > Also, the access to port 0x64 are 1 byte long, not 4, so
> >
> > ba i1 0x64
> >
> > might be more inline with what you are doing. You can also set the
> > appropriate bp in i8042prt to catch the write to the port (it is
> always
> > done in the same function).
> >
> > d
> >
> > -----Original Message-----
> > From: Phil Barila [mailto:xxxxx@Seagate.com]
> > Sent: Friday, November 01, 2002 8:56 AM
> > To: NT Developers Interest List
> > Subject: [ntdev] Re: WinDbg Question on Win2k Pro
> >
> > “Joe Moriarty” wrote in message
> > news:xxxxx@ntdev…
> > >
> > > I want to stop on a breakpoint with a write access to I/O port 64.
> > >
> > > I’m doing the following but I am not hitting the breakpoint on
> resets.
> > >
> > > bw i4 64
> > >
> > > Just making sure this is correct.
> > >
> > > Thanks In Advance,
> > > Joe
> >
> > This is better asked and answered on Windbg. Are you saving your
> > workspace
> > before you restart the target? If not, your BP is gone. If you are,
> > are
> > you setting the initial BP or BP on first symbol load? The target
> needs
> > to
> > break so Windbg can send it the right stuff to set up the BPs.
> >
> > Additionally, I can’t find any reference to bw, but ba is break on
> > access,
> > and that includes read, write, execute, and i/o, so it looks like
> your
> > syntax should be:
> >
> > ba i4 0x64
> >
> > The debugger doc for ba says:
> > Access
> > The type of access which will satisfy the breakpoint:
> > i (i/o)
> > (Windows XP and Windows .NET Server only, kernel-mode only, x86 only)
> > Breaks
> > into the debugger when the I/O port at the specified Address is
> > accessed.
> >
> > So if you aren’t running XP or newer on an IA32 CPU, you won’t be
> able
> > to
> > get it done. SoftICE can do that on older OS, I don’t know about
> IA64
> > or
> > X86-64
> >
> > Hope this helps.
> >
> > Phil
> > –
> > Philip D. Barila
> > Seagate Technology, LLC
> > (720) 684-1842
> >
> >
> >
> > —
> > You are currently subscribed to ntdev as:
> xxxxx@windows.microsoft.com
> > To unsubscribe send a blank email to %%email.unsub%%
> >
> >
> > —
> > You are currently subscribed to ntdev as: xxxxx@east.sun.com
> > To unsubscribe send a blank email to %%email.unsub%%
>
>
>
> —
> You are currently subscribed to ntdev as: xxxxx@hollistech.com
> To unsubscribe send a blank email to %%email.unsub%%

“Joe Moriarty” wrote in message
news:xxxxx@ntdev…
>
> I am getting the following error when entering the breakpoint expression
> below
>
> kd> ba i1 0x64
> I/O breakpoints not enabled
> ^ Syntax error in ‘ba i1 0x64’

The problem is in the title, I just noticed it. As you might remember, I
posted a snippet from the Windbg docs. It specifically says IO breakpoints
are only supported on XP/.NET and later OS revs.

Phil

Philip D. Barila
Seagate Technology, LLC
(720) 684-1842

Time to startup my XP image.

Thanks,
Joe

-----Original Message-----
From: xxxxx@lists.osr.com
[mailto:xxxxx@lists.osr.com]On Behalf Of Phil Barila
Sent: Tuesday, November 05, 2002 3:08 PM
To: NT Developers Interest List
Subject: [ntdev] Re: WinDbg Question on Win2k Pro

“Joe Moriarty” wrote in message
> news:xxxxx@ntdev…
> >
> > I am getting the following error when entering the breakpoint expression
> > below
> >
> > kd> ba i1 0x64
> > I/O breakpoints not enabled
> > ^ Syntax error in ‘ba i1 0x64’
>
> The problem is in the title, I just noticed it. As you might remember, I
> posted a snippet from the Windbg docs. It specifically says IO
> breakpoints
> are only supported on XP/.NET and later OS revs.
>
> Phil
> –
> Philip D. Barila
> Seagate Technology, LLC
> (720) 684-1842
>
>
>
> —
> You are currently subscribed to ntdev as: xxxxx@east.sun.com
> To unsubscribe send a blank email to %%email.unsub%%