windbg not connecting on HP-UX IA64 Win2k3 64-bit

Hi all,

I have an HP-UX IA64 machine with Windows 2003 64-bit on it. My bootcfg file is reproduced below. When I reboot the machine, Windbg on the debuggee does not respond at all. I have checked the cable and connection with hyperterm which is working fine between the two machines. Any help is appreciated.

Thanks in advance,
Pawan

Boot Options

Timeout: 30
Default: \Device\HarddiskVolume4\WINDOWS
CurrentBootEntryID: 1

Boot Entries

Boot entry ID: 1
OS Friendly Name: Copy of Copy of Windows Server 2003, Enterprise
OsLoadOptions: /noexecute=optout /debug /debugport=COM2 /baudrate=57600 /redi
rect
BootFilePath: \Device\HarddiskVolume1\EFI\Microsoft\WINNT50\ia64ldr.efi
OsFilePath: \Device\HarddiskVolume4\WINDOWS

Boot entry ID: 2
OS Friendly Name: HP-UX Primary Boot: 0/1/1/0.0.0

Boot entry ID: 3
OS Friendly Name: Internal Bootable DVD

Boot entry ID: 4
OS Friendly Name: EFI Shell [Built-in]

Boot entry ID: 5
OS Friendly Name: Drive Explorer

Boot entry ID: 6
OS Friendly Name: Copy of Windows Server 2003, Enterprise
OsLoadOptions: /noexecute=optout /redirect
BootFilePath: \Device\HarddiskVolume1\EFI\Microsoft\WINNT50\ia64ldr.efi
OsFilePath: \Device\HarddiskVolume4\WINDOWS

Did you just guess at the COM2 and baudrate? Most use 115200 for the
baudrate. I know that with one HP ia64 system there is a jumper required to
use the serial port as COM1. Did you look in the device manager at the
serial port and see what resources it is using? If it is not using the
standard PIO ports at specific addresses and a fixed IRQ, the kernel
debugger cannot use it. Server 2003 is very easy to set up since the
bootcfg utility has simple commands that are easy to type.

wrote in message news:xxxxx@windbg…
> Hi all,
>
> I have an HP-UX IA64 machine with Windows 2003 64-bit on it. My bootcfg
> file is reproduced below. When I reboot the machine, Windbg on the
> debuggee does not respond at all. I have checked the cable and connection
> with hyperterm which is working fine between the two machines. Any help is
> appreciated.
>
> Thanks in advance,
> Pawan
>
> Boot Options
> ------------
> Timeout: 30
> Default: \Device\HarddiskVolume4\WINDOWS
> CurrentBootEntryID: 1
>
> Boot Entries
> ------------
>
> Boot entry ID: 1
> OS Friendly Name: Copy of Copy of Windows Server 2003, Enterprise
> OsLoadOptions: /noexecute=optout /debug /debugport=COM2 /baudrate=57600
> /redi
> rect
> BootFilePath:
> \Device\HarddiskVolume1\EFI\Microsoft\WINNT50\ia64ldr.efi
> OsFilePath: \Device\HarddiskVolume4\WINDOWS
>
> Boot entry ID: 2
> OS Friendly Name: HP-UX Primary Boot: 0/1/1/0.0.0
>
> Boot entry ID: 3
> OS Friendly Name: Internal Bootable DVD
>
> Boot entry ID: 4
> OS Friendly Name: EFI Shell [Built-in]
>
> Boot entry ID: 5
> OS Friendly Name: Drive Explorer
>
> Boot entry ID: 6
> OS Friendly Name: Copy of Windows Server 2003, Enterprise
> OsLoadOptions: /noexecute=optout /redirect
> BootFilePath:
> \Device\HarddiskVolume1\EFI\Microsoft\WINNT50\ia64ldr.efi
> OsFilePath: \Device\HarddiskVolume4\WINDOWS
>
>

No I did not guess. I used the same COM port number as device manager was showing. Moreover, using hyperterm on same ports, I was able to communicate.

Hi Craig,
Yes may be you are right. On this machine, compared to my 32 bit machine, the port is using an IRQ of 34 instead of 4 and instead of IO ports, its in the PCI memory range.