Turning on KMDF Verifier

I seem to be having trouble turning on the KMDF Verifier.

I followed the instructions and !wdfkd.wdfdriverinfo cmd showed me it was
turned on for my driver.

I made some corrections and updated the driver. Although the registry
still shows the verifier is on !wdfkd.wdfdriverinfo shows it is off.

I tried deleting the registry key and repeating the enable process but
cannot get it back on.

Has anyone else seen this problem or have an idea what I may be doing
wrong.

Thanks in advance
Phil.

What OS? For win7 if you turn on normal DV, the KMDF verifier turns on automatically as well.

d

From: xxxxx@lists.osr.com [mailto:xxxxx@lists.osr.com] On Behalf Of xxxxx@agfa.com
Sent: Wednesday, April 14, 2010 10:41 AM
To: Windows System Software Devs Interest List
Subject: [ntdev] Turning on KMDF Verifier

I seem to be having trouble turning on the KMDF Verifier.

I followed the instructions and !wdfkd.wdfdriverinfo cmd showed me it was turned on for my driver.

I made some corrections and updated the driver. Although the registry still shows the verifier is on !wdfkd.wdfdriverinfo shows it is off.

I tried deleting the registry key and repeating the enable process but cannot get it back on.

Has anyone else seen this problem or have an idea what I may be doing wrong.

Thanks in advance
Phil.
— NTDEV is sponsored by OSR For our schedule of WDF, WDM, debugging and other seminars visit: http://www.osr.com/seminars To unsubscribe, visit the List Server section of OSR Online at http://www.osronline.com/page.cfm?name=ListServer

You could also try enabling it using the WdfVerifier.exe tool that’s part of the WDK.
wrote in message news:xxxxx@ntdev…

I seem to be having trouble turning on the KMDF Verifier.

I followed the instructions and !wdfkd.wdfdriverinfo cmd showed me it was turned on for my driver.

I made some corrections and updated the driver. Although the registry still shows the verifier is on !wdfkd.wdfdriverinfo shows it is off.

I tried deleting the registry key and repeating the enable process but cannot get it back on.

Has anyone else seen this problem or have an idea what I may be doing wrong.

Thanks in advance
Phil.