Problems with softice

Hi everyone,

I am having a problem with softice video support. I have a Dell Precision
420 computer with Matrox G450 video card, Win2kSp1. Softice is set up to as
a Boot time driver. When it starts up, before GUI, it comes up in 60 line
full screen mode. I set a breakpoint in my code (driver) and do a go. The
breakpoint hits before the GUI, so I come up in the same 60 line full screen
mode. I continue from there (F5), and let Windows come up. If I go into
softice now, video is turned off and I am driving softice in the blind. I
can continue, and Windows works and picks up just fine. If I do the same
thing but without the initial breakpoint, softice comes up after the Windows
GUI just fine, in a window (not full screen) (100 wide by 93 lines). I am
running Universal video Driver for softice, and latest Matrox video drivers
for Win2k. My windows UI is in 1280x1024.

Anyone know what the problem is?

Thanks in advance for the help.

Toly


You are currently subscribed to ntdev as: $subst(‘Recip.EmailAddr’)
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com

Add this option to your BOOT.ini file (/noguiboot)
it should appear like this

multi(0)disk(0)rdisk(0)partition(1)\WINNT=“Microsoft Windows 2000
Professional” /fastdetect /noguiboot

----- Original Message -----
From: “Toly Menn”
To: “NT Developers Interest List”
Sent: Thursday, May 03, 2001 2:57 AM
Subject: [ntdev] Problems with softice

> Hi everyone,
>
> I am having a problem with softice video support. I have a Dell Precision
> 420 computer with Matrox G450 video card, Win2kSp1. Softice is set up to
as
> a Boot time driver. When it starts up, before GUI, it comes up in 60 line
> full screen mode. I set a breakpoint in my code (driver) and do a go.
The
> breakpoint hits before the GUI, so I come up in the same 60 line full
screen
> mode. I continue from there (F5), and let Windows come up. If I go into
> softice now, video is turned off and I am driving softice in the blind. I
> can continue, and Windows works and picks up just fine. If I do the same
> thing but without the initial breakpoint, softice comes up after the
Windows
> GUI just fine, in a window (not full screen) (100 wide by 93 lines). I am
> running Universal video Driver for softice, and latest Matrox video
drivers
> for Win2k. My windows UI is in 1280x1024.
>
> Anyone know what the problem is?
>
> Thanks in advance for the help.
>
> Toly
>
> —
> You are currently subscribed to ntdev as: xxxxx@yahoo.com
> To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com

_________________________________________________________

Do You Yahoo!?

Get your free @yahoo.com address at http://mail.yahoo.com


You are currently subscribed to ntdev as: $subst(‘Recip.EmailAddr’)
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com

Thanks for the suggestion. I already had the /noguiboot switch in the
boot.ini, even though I have no idea what it does. A quick response from
Softice team solved the problem by removing the lines 100;width 100; part
of my softice init string. After sofice is up, I am able to issue these
commands and things work just fine.

Thanks, Toly

-----Original Message-----
From: Hesham Desokey [mailto:xxxxx@yahoo.com]
Sent: Thursday, May 03, 2001 0:32
To: NT Developers Interest List
Subject: [ntdev] Re: Problems with softice

Add this option to your BOOT.ini file (/noguiboot)
it should appear like this

multi(0)disk(0)rdisk(0)partition(1)\WINNT=“Microsoft Windows 2000
Professional” /fastdetect /noguiboot

----- Original Message -----
From: “Toly Menn”
To: “NT Developers Interest List”
Sent: Thursday, May 03, 2001 2:57 AM
Subject: [ntdev] Problems with softice

> Hi everyone,
>
> I am having a problem with softice video support. I have a Dell Precision
> 420 computer with Matrox G450 video card, Win2kSp1. Softice is set up to
as
> a Boot time driver. When it starts up, before GUI, it comes up in 60 line
> full screen mode. I set a breakpoint in my code (driver) and do a go.
The
> breakpoint hits before the GUI, so I come up in the same 60 line full
screen
> mode. I continue from there (F5), and let Windows come up. If I go into
> softice now, video is turned off and I am driving softice in the blind. I
> can continue, and Windows works and picks up just fine. If I do the same
> thing but without the initial breakpoint, softice comes up after the
Windows
> GUI just fine, in a window (not full screen) (100 wide by 93 lines). I am
> running Universal video Driver for softice, and latest Matrox video
drivers
> for Win2k. My windows UI is in 1280x1024.
>
> Anyone know what the problem is?
>
> Thanks in advance for the help.
>
> Toly
>
> —
> You are currently subscribed to ntdev as: xxxxx@yahoo.com
> To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com

_________________________________________________________

Do You Yahoo!?

Get your free @yahoo.com address at http://mail.yahoo.com


You are currently subscribed to ntdev as: xxxxx@nmwco.com
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com


You are currently subscribed to ntdev as: $subst(‘Recip.EmailAddr’)
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com

Im happy that your problems solved, but I need to clarify some points
the /noguiboot option is very ncessary for softice to laod the softice
during windows 2K starting up
this option remove the Graphical boot of windows which seems it make trouble
for initializing the softice loader
hesham
----- Original Message -----
From: “Toly Menn”
To: “NT Developers Interest List”
Sent: Friday, May 04, 2001 10:30 PM
Subject: [ntdev] Re: Problems with softice

> Thanks for the suggestion. I already had the /noguiboot switch in the
> boot.ini, even though I have no idea what it does. A quick response from
> Softice team solved the problem by removing the lines 100;width 100; part
> of my softice init string. After sofice is up, I am able to issue these
> commands and things work just fine.
>
> Thanks, Toly
>
>
> -----Original Message-----
> From: Hesham Desokey [mailto:xxxxx@yahoo.com]
> Sent: Thursday, May 03, 2001 0:32
> To: NT Developers Interest List
> Subject: [ntdev] Re: Problems with softice
>
> Add this option to your BOOT.ini file (/noguiboot)
> it should appear like this
>
> multi(0)disk(0)rdisk(0)partition(1)\WINNT=“Microsoft Windows 2000
> Professional” /fastdetect /noguiboot
>
> ----- Original Message -----
> From: “Toly Menn”
> To: “NT Developers Interest List”
> Sent: Thursday, May 03, 2001 2:57 AM
> Subject: [ntdev] Problems with softice
>
>
> > Hi everyone,
> >
> > I am having a problem with softice video support. I have a Dell
Precision
> > 420 computer with Matrox G450 video card, Win2kSp1. Softice is set up
to
> as
> > a Boot time driver. When it starts up, before GUI, it comes up in 60
line
> > full screen mode. I set a breakpoint in my code (driver) and do a go.
> The
> > breakpoint hits before the GUI, so I come up in the same 60 line full
> screen
> > mode. I continue from there (F5), and let Windows come up. If I go
into
> > softice now, video is turned off and I am driving softice in the blind.
I
> > can continue, and Windows works and picks up just fine. If I do the
same
> > thing but without the initial breakpoint, softice comes up after the
> Windows
> > GUI just fine, in a window (not full screen) (100 wide by 93 lines). I
am
> > running Universal video Driver for softice, and latest Matrox video
> drivers
> > for Win2k. My windows UI is in 1280x1024.
> >
> > Anyone know what the problem is?
> >
> > Thanks in advance for the help.
> >
> > Toly
> >
> > —
> > You are currently subscribed to ntdev as: xxxxx@yahoo.com
> > To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com
>
>
>
>
>
> Do You Yahoo!?
>
> Get your free @yahoo.com address at http://mail.yahoo.com
>
>
>
>
> —
> You are currently subscribed to ntdev as: xxxxx@nmwco.com
> To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com
>
> —
> You are currently subscribed to ntdev as: xxxxx@yahoo.com
> To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com



Do You Yahoo!?

Get your free @yahoo.com address at http://mail.yahoo.com


You are currently subscribed to ntdev as: $subst(‘Recip.EmailAddr’)
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com

Actually there’s another reason of our own to add the /noguiboot. This is
to allow the end user to see the “Press ESC to cancel loading BLAH”
messages, where “blah” is one of our drivers such as SoftIce, BoundsChecker
or SiwVid. This is necessary for trouble shooting and for those times when
things just don’t mix well together. However, the loader for win2k puts the
system into a funky vga mode that softice is not as yet set up to handle,
hence another need for /noguiboot, or you’re not going to be able to read
the screen that SoftIce pops up. Due to the reason we like to see those
“Press ESC” messages at boot time, we haven’t as yet put any effort in
handling that vga mode.

Alberto.

-----Original Message-----
From: Hesham Desokey [mailto:xxxxx@yahoo.com]
Sent: Friday, May 04, 2001 7:04 PM
To: NT Developers Interest List
Subject: [ntdev] Re: Problems with softice

Im happy that your problems solved, but I need to clarify some points
the /noguiboot option is very ncessary for softice to laod the softice
during windows 2K starting up
this option remove the Graphical boot of windows which seems it make trouble
for initializing the softice loader
hesham
----- Original Message -----
From: “Toly Menn”
To: “NT Developers Interest List”
Sent: Friday, May 04, 2001 10:30 PM
Subject: [ntdev] Re: Problems with softice

> Thanks for the suggestion. I already had the /noguiboot switch in the
> boot.ini, even though I have no idea what it does. A quick response from
> Softice team solved the problem by removing the lines 100;width 100; part
> of my softice init string. After sofice is up, I am able to issue these
> commands and things work just fine.
>
> Thanks, Toly
>
>
> -----Original Message-----
> From: Hesham Desokey [mailto:xxxxx@yahoo.com]
> Sent: Thursday, May 03, 2001 0:32
> To: NT Developers Interest List
> Subject: [ntdev] Re: Problems with softice
>
> Add this option to your BOOT.ini file (/noguiboot)
> it should appear like this
>
> multi(0)disk(0)rdisk(0)partition(1)\WINNT=“Microsoft Windows 2000
> Professional” /fastdetect /noguiboot
>
> ----- Original Message -----
> From: “Toly Menn”
> To: “NT Developers Interest List”
> Sent: Thursday, May 03, 2001 2:57 AM
> Subject: [ntdev] Problems with softice
>
>
> > Hi everyone,
> >
> > I am having a problem with softice video support. I have a Dell
Precision
> > 420 computer with Matrox G450 video card, Win2kSp1. Softice is set up
to
> as
> > a Boot time driver. When it starts up, before GUI, it comes up in 60
line
> > full screen mode. I set a breakpoint in my code (driver) and do a go.
> The
> > breakpoint hits before the GUI, so I come up in the same 60 line full
> screen
> > mode. I continue from there (F5), and let Windows come up. If I go
into
> > softice now, video is turned off and I am driving softice in the blind.
I
> > can continue, and Windows works and picks up just fine. If I do the
same
> > thing but without the initial breakpoint, softice comes up after the
> Windows
> > GUI just fine, in a window (not full screen) (100 wide by 93 lines). I
am
> > running Universal video Driver for softice, and latest Matrox video
> drivers
> > for Win2k. My windows UI is in 1280x1024.
> >
> > Anyone know what the problem is?
> >
> > Thanks in advance for the help.
> >
> > Toly
> >
> > —
> > You are currently subscribed to ntdev as: xxxxx@yahoo.com
> > To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com
>
>
>
>
>
> Do You Yahoo!?
>
> Get your free @yahoo.com address at http://mail.yahoo.com
>
>
>
>
> —
> You are currently subscribed to ntdev as: xxxxx@nmwco.com
> To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com
>
> —
> You are currently subscribed to ntdev as: xxxxx@yahoo.com
> To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com



Do You Yahoo!?

Get your free @yahoo.com address at http://mail.yahoo.com


You are currently subscribed to ntdev as: xxxxx@compuware.com
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com


You are currently subscribed to ntdev as: $subst(‘Recip.EmailAddr’)
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com