problem with windbg setup with pcmcia card on vista

Hi,

I am trying to setup my system for remote debugging. Both debugger and debugee have vista on them. the target has checked build of vista.

The target does not have a firewire port so i have to use a pcmcia card. The pcmcia card as a firewire and USB ports. When I boot the target in normal mode the pcmcia card is detected fine and any usb device plugged in the usb port of the pcmcia card works fine. However when I boot the target machine in debug mode the pcmcia card is not detected at all and even if I plug in a usb device in the usb port of the pcmcia card, that doesn’t work as well.

To boot in debug mode I check the debug options in msconfig and set debug port as 1394.

Is there a problem in the pcmcia card or is it a problem with vista starting in debug mode?

Thanks
Mudeem

On the target system. Try the following command and then reboot to see if
that helps.

bcdedit /debug
bcdedit /dbgsettings /1394 CHANNEL:23

On Sat, Jul 19, 2008 at 6:59 AM, wrote:

> Hi,
>
> I am trying to setup my system for remote debugging. Both debugger and
> debugee have vista on them. the target has checked build of vista.
>
> The target does not have a firewire port so i have to use a pcmcia card.
> The pcmcia card as a firewire and USB ports. When I boot the target in
> normal mode the pcmcia card is detected fine and any usb device plugged in
> the usb port of the pcmcia card works fine. However when I boot the target
> machine in debug mode the pcmcia card is not detected at all and even if I
> plug in a usb device in the usb port of the pcmcia card, that doesn’t work
> as well.
>
> To boot in debug mode I check the debug options in msconfig and set debug
> port as 1394.
>
> Is there a problem in the pcmcia card or is it a problem with vista
> starting in debug mode?
>
> Thanks
> Mudeem
>
> —
> You are currently subscribed to windbg as: xxxxx@eccellente-it.com
> To unsubscribe send a blank email to xxxxx@lists.osr.com
>


Thanks & Regards

Pushkar Prasad | Email: xxxxx@eccellente-it.com | URL:
http://www.eccellente-it.com |

“A positive attitude may not solve all your problems, but it will annoy
enough people to make it worth the effort.” -Herm Albright

I don’t know if a PCMCIA 1394 card will work with WinDbg; my guess would be that it won’t.

Good luck,

mm

Pushkar Prasad wrote:

On the target system. Try the following command and then reboot to see
if that helps.

bcdedit /debug
bcdedit /dbgsettings /1394 CHANNEL:23

On Sat, Jul 19, 2008 at 6:59 AM, > mailto:xxxxx> wrote:
>
> Hi,
>
> I am trying to setup my system for remote debugging. Both debugger
> and debugee have vista on them. the target has checked build of vista.
>
> The target does not have a firewire port so i have to use a pcmcia
> card. The pcmcia card as a firewire and USB ports. When I boot the
> target in normal mode the pcmcia card is detected fine and any usb
> device plugged in the usb port of the pcmcia card works fine.
> However when I boot the target machine in debug mode the pcmcia card
> is not detected at all and even if I plug in a usb device in the usb
> port of the pcmcia card, that doesn’t work as well.
>
> To boot in debug mode I check the debug options in msconfig and set
> debug port as 1394.
>
> Is there a problem in the pcmcia card or is it a problem with vista
> starting in debug mode?
>
> Thanks
> Mudeem
>
> —
> You are currently subscribed to windbg as:
> xxxxx@eccellente-it.com mailto:xxxxx
> To unsubscribe send a blank email to
> xxxxx@lists.osr.com
> mailto:xxxxx
>
>
>
>
> –
> Thanks & Regards
>
> Pushkar Prasad | Email: xxxxx@eccellente-it.com
> mailto:xxxxx | URL: http://www.eccellente-it.com |
>
> “A positive attitude may not solve all your problems, but it will annoy
> enough people to make it worth the effort.” -Herm Albright</mailto:xxxxx></mailto:xxxxx></mailto:xxxxx></mailto:xxxxx>

That should read ‘my guess would be that there’s a pretty good chance that most won’t.’ I would post what you are using, and see if
anyone knows of one that definitely does work.

Good luck,

mm

Martin O’Brien wrote:

I don’t know if a PCMCIA 1394 card will work with WinDbg; my guess would
be that it won’t.

Good luck,

mm

Pushkar Prasad wrote:
> On the target system. Try the following command and then reboot to see
> if that helps.
>
> bcdedit /debug
> bcdedit /dbgsettings /1394 CHANNEL:23
>
> On Sat, Jul 19, 2008 at 6:59 AM, >> mailto:xxxxx> wrote:
>>
>> Hi,
>>
>> I am trying to setup my system for remote debugging. Both debugger
>> and debugee have vista on them. the target has checked build of
>> vista.
>>
>> The target does not have a firewire port so i have to use a pcmcia
>> card. The pcmcia card as a firewire and USB ports. When I boot the
>> target in normal mode the pcmcia card is detected fine and any usb
>> device plugged in the usb port of the pcmcia card works fine.
>> However when I boot the target machine in debug mode the pcmcia card
>> is not detected at all and even if I plug in a usb device in the usb
>> port of the pcmcia card, that doesn’t work as well.
>>
>> To boot in debug mode I check the debug options in msconfig and set
>> debug port as 1394.
>>
>> Is there a problem in the pcmcia card or is it a problem with vista
>> starting in debug mode?
>>
>> Thanks
>> Mudeem
>>
>> —
>> You are currently subscribed to windbg as:
>> xxxxx@eccellente-it.com mailto:xxxxx
>> To unsubscribe send a blank email to
>> xxxxx@lists.osr.com
>> mailto:xxxxx
>>
>>
>>
>>
>> –
>> Thanks & Regards
>>
>> Pushkar Prasad | Email: xxxxx@eccellente-it.com
>> mailto:xxxxx | URL: http://www.eccellente-it.com |
>>
>> “A positive attitude may not solve all your problems, but it will
>> annoy enough people to make it worth the effort.” -Herm Albright
></mailto:xxxxx></mailto:xxxxx></mailto:xxxxx></mailto:xxxxx>

In general, if hardware does not emulate the PCI version, the kernel does
not know how to talk to it.
Since a PCMCIA card needs a different bus driver it most likely will not
work.
Since it is Vista, try USB. You need a special cable.

On Sat, Jul 19, 2008 at 1:50 PM, Martin O’Brien
wrote:

> That should read ‘my guess would be that there’s a pretty good chance that
> most won’t.’ I would post what you are using, and see if anyone knows of
> one that definitely does work.
>
>
> Good luck,
>
> mm
>
> Martin O’Brien wrote:
>
>> I don’t know if a PCMCIA 1394 card will work with WinDbg; my guess would
>> be that it won’t.
>>
>> Good luck,
>>
>> mm
>>
>> Pushkar Prasad wrote:
>>
>>> On the target system. Try the following command and then reboot to see if
>>> that helps.
>>> bcdedit /debug
>>> bcdedit /dbgsettings /1394 CHANNEL:23
>>>
>>> On Sat, Jul 19, 2008 at 6:59 AM, >>> xxxxx@quartics.com>> wrote:
>>>
>>> Hi,
>>>
>>> I am trying to setup my system for remote debugging. Both debugger
>>> and debugee have vista on them. the target has checked build of vista.
>>>
>>> The target does not have a firewire port so i have to use a pcmcia
>>> card. The pcmcia card as a firewire and USB ports. When I boot the
>>> target in normal mode the pcmcia card is detected fine and any usb
>>> device plugged in the usb port of the pcmcia card works fine.
>>> However when I boot the target machine in debug mode the pcmcia card
>>> is not detected at all and even if I plug in a usb device in the usb
>>> port of the pcmcia card, that doesn’t work as well.
>>>
>>> To boot in debug mode I check the debug options in msconfig and set
>>> debug port as 1394.
>>>
>>> Is there a problem in the pcmcia card or is it a problem with vista
>>> starting in debug mode?
>>>
>>> Thanks
>>> Mudeem
>>>
>>> —
>>> You are currently subscribed to windbg as:
>>> xxxxx@eccellente-it.com mailto:xxxxx
>>> To unsubscribe send a blank email to
>>> xxxxx@lists.osr.com
>>> mailto:xxxxx
>>>
>>>
>>>
>>>
>>> –
>>> Thanks & Regards
>>>
>>> Pushkar Prasad | Email: xxxxx@eccellente-it.com mailto:>>> xxxxx@eccellente-it.com> | URL: http://www.eccellente-it.com |
>>>
>>> “A positive attitude may not solve all your problems, but it will annoy
>>> enough people to make it worth the effort.” -Herm Albright
>>>
>>
>>
> —
> You are currently subscribed to windbg as: xxxxx@jimdonelson.com
> To unsubscribe send a blank email to xxxxx@lists.osr.com
></mailto:></mailto:xxxxx></mailto:xxxxx>

PCMCIA 1394 works with?Vista. I have tried with channel 44 and 1. Make sure you set the channel # in msconfig. It’s disabled by default.
Also check if the PCMCIA drivers are installed properly on both systems. Reboot both before you try to connect.
Regards.

----- Original Message ----
From: Kernel Debugging Interest List digest
To: windbg digest recipients
Sent: Sunday, July 20, 2008 10:30:02 AM
Subject: windbg digest: July 19, 2008

WINDBG Digest for Saturday, July 19, 2008.

1. Re: problem with windbg setup with pcmcia card on vista
2. Re: problem with windbg setup with pcmcia card on vista
3. Re: problem with windbg setup with pcmcia card on vista

----------------------------------------------------------------------

Subject: Re: problem with windbg setup with pcmcia card on vista
From: Martin O’Brien
Date: Sat, 19 Jul 2008 13:49:18 -0400
X-Message-Number: 1

I don’t know if a PCMCIA 1394 card will work with WinDbg; my guess would be that it won’t.

Good luck,

mm

Pushkar Prasad wrote:
> On the target system. Try the following command and then reboot to see
> if that helps.
>?
> bcdedit /debug
> bcdedit /dbgsettings /1394 CHANNEL:23
>
> On Sat, Jul 19, 2008 at 6:59 AM, > mailto:xxxxx> wrote:
>
>? ? Hi,
>
>? ? I am trying to setup my system for remote debugging. Both debugger
>? ? and debugee have vista on them. the target has checked build of vista.
>
>? ? The target does not have a firewire port so i have to use a pcmcia
>? ? card. The pcmcia card as a firewire and USB ports. When I boot the
>? ? target in normal mode the pcmcia card is detected fine and any usb
>? ? device plugged in the usb port of the pcmcia card works fine.
>? ? However when I boot the target machine in debug mode the pcmcia card
>? ? is not detected at all and even if I plug in a usb device in the usb
>? ? port of the pcmcia card, that doesn’t work as well.
>
>? ? To boot in debug mode I check the debug options in msconfig and set
>? ? debug port as 1394.
>
>? ? Is there a problem in the pcmcia card or is it a problem with vista
>? ? starting in debug mode?
>
>? ? Thanks
>? ? Mudeem
>
>? ? —
>? ? You are currently subscribed to windbg as:
>? ? xxxxx@eccellente-it.com mailto:xxxxx
>? ? To unsubscribe send a blank email to
>? ? xxxxx@lists.osr.com
>? ? mailto:xxxxx
>
>
>
>
> –
> Thanks & Regards
>
> Pushkar Prasad | Email: xxxxx@eccellente-it.com
> mailto:xxxxx | URL: http://www.eccellente-it.com |
>
> “A positive attitude may not solve all your problems, but it will annoy
> enough people to make it worth the effort.” -Herm Albright

----------------------------------------------------------------------

Subject: Re: problem with windbg setup with pcmcia card on vista
From: Martin O’Brien
Date: Sat, 19 Jul 2008 13:50:26 -0400
X-Message-Number: 2

That should read ‘my guess would be that there’s a pretty good chance that most won’t.’? I would post what you are using, and see if
anyone knows of one that definitely does work.

Good luck,

mm

Martin O’Brien wrote:
> I don’t know if a PCMCIA 1394 card will work with WinDbg; my guess would
> be that it won’t.
>
> Good luck,
>
> mm
>
> Pushkar Prasad wrote:
>> On the target system. Try the following command and then reboot to see
>> if that helps.
>>?
>> bcdedit /debug
>> bcdedit /dbgsettings /1394 CHANNEL:23
>>
>> On Sat, Jul 19, 2008 at 6:59 AM, >> mailto:xxxxx> wrote:
>>
>>? ? Hi,
>>
>>? ? I am trying to setup my system for remote debugging. Both debugger
>>? ? and debugee have vista on them. the target has checked build of
>> vista.
>>
>>? ? The target does not have a firewire port so i have to use a pcmcia
>>? ? card. The pcmcia card as a firewire and USB ports. When I boot the
>>? ? target in normal mode the pcmcia card is detected fine and any usb
>>? ? device plugged in the usb port of the pcmcia card works fine.
>>? ? However when I boot the target machine in debug mode the pcmcia card
>>? ? is not detected at all and even if I plug in a usb device in the usb
>>? ? port of the pcmcia card, that doesn’t work as well.
>>
>>? ? To boot in debug mode I check the debug options in msconfig and set
>>? ? debug port as 1394.
>>
>>? ? Is there a problem in the pcmcia card or is it a problem with vista
>>? ? starting in debug mode?
>>
>>? ? Thanks
>>? ? Mudeem
>>
>>? ? —
>>? ? You are currently subscribed to windbg as:
>>? ? xxxxx@eccellente-it.com mailto:xxxxx
>>? ? To unsubscribe send a blank email to
>>? ? xxxxx@lists.osr.com
>>? ? mailto:xxxxx
>>
>>
>>
>>
>> –
>> Thanks & Regards
>>
>> Pushkar Prasad | Email: xxxxx@eccellente-it.com
>> mailto:xxxxx | URL: http://www.eccellente-it.com |
>>
>> “A positive attitude may not solve all your problems, but it will
>> annoy enough people to make it worth the effort.” -Herm Albright
>

----------------------------------------------------------------------

Subject: Re: problem with windbg setup with pcmcia card on vista
From: “Jim Donelson”
Date: Sat, 19 Jul 2008 13:54:18 -0400
X-Message-Number: 3

In general, if hardware does not emulate the PCI version, the kernel does
not know how to talk to it.
Since a PCMCIA card needs a different bus driver it most likely will not
work.
Since it is Vista, try USB. You need a special cable.

On Sat, Jul 19, 2008 at 1:50 PM, Martin O’Brien
wrote:

> That should read ‘my guess would be that there’s a pretty good chance that
> most won’t.’? I would post what you are using, and see if anyone knows of
> one that definitely does work.
>
>
> Good luck,
>
> mm
>
> Martin O’Brien wrote:
>
>> I don’t know if a PCMCIA 1394 card will work with WinDbg; my guess would
>> be that it won’t.
>>
>> Good luck,
>>
>> mm
>>
>> Pushkar Prasad wrote:
>>
>>> On the target system. Try the following command and then reboot to see if
>>> that helps.
>>>? bcdedit /debug
>>> bcdedit /dbgsettings /1394 CHANNEL:23
>>>
>>> On Sat, Jul 19, 2008 at 6:59 AM, >>> xxxxx@quartics.com>> wrote:
>>>
>>>? ? Hi,
>>>
>>>? ? I am trying to setup my system for remote debugging. Both debugger
>>>? ? and debugee have vista on them. the target has checked build of vista.
>>>
>>>? ? The target does not have a firewire port so i have to use a pcmcia
>>>? ? card. The pcmcia card as a firewire and USB ports. When I boot the
>>>? ? target in normal mode the pcmcia card is detected fine and any usb
>>>? ? device plugged in the usb port of the pcmcia card works fine.
>>>? ? However when I boot the target machine in debug mode the pcmcia card
>>>? ? is not detected at all and even if I plug in a usb device in the usb
>>>? ? port of the pcmcia card, that doesn’t work as well.
>>>
>>>? ? To boot in debug mode I check the debug options in msconfig and set
>>>? ? debug port as 1394.
>>>
>>>? ? Is there a problem in the pcmcia card or is it a problem with vista
>>>? ? starting in debug mode?
>>>
>>>? ? Thanks
>>>? ? Mudeem
>>>
>>>? ? —
>>>? ? You are currently subscribed to windbg as:
>>>? ? xxxxx@eccellente-it.com mailto:xxxxx
>>>? ? To unsubscribe send a blank email to
>>>? ? xxxxx@lists.osr.com
>>>? ? mailto:xxxxx
>>>
>>>
>>>
>>>
>>> –
>>> Thanks & Regards
>>>
>>> Pushkar Prasad | Email: xxxxx@eccellente-it.com mailto:>>> xxxxx@eccellente-it.com> | URL: http://www.eccellente-it.com |
>>>
>>> “A positive attitude may not solve all your problems, but it will annoy
>>> enough people to make it worth the effort.” -Herm Albright
>>>
>>
>>
> —
> You are currently subscribed to windbg as: xxxxx@jimdonelson.com
> To unsubscribe send a blank email to xxxxx@lists.osr.com
>



END OF DIGEST


You are currently subscribed to windbg as: xxxxx@yahoo.com
To unsubscribe send a blank email to xxxxx@lists.osr.com</mailto:></mailto:xxxxx></mailto:xxxxx></mailto:xxxxx></mailto:xxxxx></mailto:xxxxx></mailto:xxxxx></mailto:xxxxx></mailto:xxxxx></mailto:xxxxx></mailto:xxxxx>

I have struggle quite a lot with this but I guess becuase pcmcia card is
a plug and play device and during the boot the the pcmcia bus driver
does not get loaded till a latter time thus the target does not break
into the debugger.


From: xxxxx@lists.osr.com
[mailto:xxxxx@lists.osr.com] On Behalf Of Jim Donelson
Sent: Saturday, July 19, 2008 10:54 AM
To: Kernel Debugging Interest List
Subject: Re: [windbg] problem with windbg setup with pcmcia card on
vista

In general, if hardware does not emulate the PCI version, the kernel
does not know how to talk to it.
Since a PCMCIA card needs a different bus driver it most likely will not
work.
Since it is Vista, try USB. You need a special cable.

On Sat, Jul 19, 2008 at 1:50 PM, Martin O’Brien
wrote:

That should read ‘my guess would be that there’s a pretty good
chance that most won’t.’ I would post what you are using, and see if
anyone knows of one that definitely does work.

Good luck,

mm

Martin O’Brien wrote:

I don’t know if a PCMCIA 1394 card will work with
WinDbg; my guess would be that it won’t.

Good luck,

mm

Pushkar Prasad wrote:

On the target system. Try the following command
and then reboot to see if that helps.
bcdedit /debug
bcdedit /dbgsettings /1394 CHANNEL:23

On Sat, Jul 19, 2008 at 6:59 AM,
> wrote:

Hi,

I am trying to setup my system for remote
debugging. Both debugger
and debugee have vista on them. the target
has checked build of vista.

The target does not have a firewire port so i
have to use a pcmcia
card. The pcmcia card as a firewire and USB
ports. When I boot the
target in normal mode the pcmcia card is
detected fine and any usb
device plugged in the usb port of the pcmcia
card works fine.
However when I boot the target machine in
debug mode the pcmcia card
is not detected at all and even if I plug in
a usb device in the usb
port of the pcmcia card, that doesn’t work as
well.

To boot in debug mode I check the debug
options in msconfig and set
debug port as 1394.

Is there a problem in the pcmcia card or is
it a problem with vista
starting in debug mode?

Thanks
Mudeem


You are currently subscribed to windbg as:

xxxxx@eccellente-it.com
mailto:xxxxx

To unsubscribe send a blank email to

xxxxx@lists.osr.com
mailto:xxxxx


Thanks & Regards

Pushkar Prasad | Email:
xxxxx@eccellente-it.com mailto:xxxxx | URL:
http://www.eccellente-it.com |

“A positive attitude may not solve all your
problems, but it will annoy enough people to make it worth the effort.”
-Herm Albright



You are currently subscribed to windbg as: xxxxx@jimdonelson.com

To unsubscribe send a blank email to
xxxxx@lists.osr.com

— You are currently subscribed to windbg as: xxxxx@quartics.com To
unsubscribe send a blank email to xxxxx@lists.osr.com</mailto:xxxxx></mailto:xxxxx></mailto:xxxxx>