"obj_path is set for you" error with WDK 5600

If is use the 5308 WDK my build of the example code for Sample WDF Driver
for Sealevel Digital I/O Kit is works great.

Performing Makefile project actions
1>BUILD: Compile and Link for x86
1>BUILD: Loading c:\winddk\5308\build.dat…
1>BUILD: Computing Include file dependencies:
1>BUILD: Examining c:\winddk\wdf\kmdf10\src\kmdf\apollo directory for files
to compile.
1> c:\winddk\wdf\kmdf10\src\kmdf\apollo
1>BUILD: Saving c:\winddk\5308\build.dat…
1>BUILD: Linking c:\winddk\wdf\kmdf10\src\kmdf\apollo directory
1>1>_NT_TARGET_VERSION SET TO WINXP
1>BUILD: Done

If is use the 5600 WDK my build of the example code for Sample WDF Driver
for Sealevel Digital I/O Kit gets the following error. Any ideas?

Performing Makefile project actions
1>BUILD: Compile and Link for x86
1>BUILD: Loading c:\winddk\5600\build.dat…
1>BUILD: Computing Include file dependencies:
1>BUILD: Start time: Thu Oct 05 16:15:17 2006
1>errors in directory c:\winddk\wdf\kmdf10\src\kmdf\apollo
1>obj_path is set for you. You may not set it.
1>obj_path is set for you. You may not set it.
1>BUILD: Examining c:\winddk\wdf\kmdf10\src\kmdf\apollo directory for files
to compile.
1> c:\winddk\wdf\kmdf10\src\kmdf\apollo
1>BUILD: Saving c:\winddk\5600\build.dat…
1>BUILD: Compile errors: not linking c:\winddk\wdf\kmdf10\src\kmdf\apollo
directory
1>BUILD: Finish time: Thu Oct 05 16:15:29 2006
1>BUILD: Done
1> 0 files compiled - 2 Errors

This is the batch file I use for the 2 builds, just rem out either line to
try either build.

rem call C:\WINDDK\5308\bin\setenv.bat C:\WINDDK\5308 fre WXP
call C:\WINDDK\5600\bin\setenv.bat C:\WINDDK\5600\ fre WXP
cd C:\WINDDK\WDF\KMDF10\src\kmdf\apollo
call …....\set_wdf_env.cmd

Thanks,
Greg

Take out the set_wdf_env call. I think the 5600 build includes it natively. I had this problem a few days ago!

jorj

That got rid of one error:

BUILD: Compile and Link for x86
1>BUILD: Loading c:\winddk\5600\build.dat…
1>BUILD: Computing Include file dependencies:
1>BUILD: Start time: Thu Oct 05 16:42:07 2006
1>errors in directory c:\winddk\wdf\kmdf10\src\kmdf\apollo
1>obj_path is set for you. You may not set it.
1>BUILD: Examining c:\winddk\wdf\kmdf10\src\kmdf\apollo directory for files
to compile.
1> c:\winddk\wdf\kmdf10\src\kmdf\apollo
1>BUILD: Saving c:\winddk\5600\build.dat…
1>BUILD: Compile errors: not linking c:\winddk\wdf\kmdf10\src\kmdf\apollo
directory
1>BUILD: Finish time: Thu Oct 05 16:42:08 2006
1>BUILD: Done
1> 0 files compiled - 1 Error

The batch file is now:
rem call C:\WINDDK\5308\bin\setenv.bat C:\WINDDK\5308 fre WXP
call C:\WINDDK\5600\bin\setenv.bat C:\WINDDK\5600\ fre WXP
cd C:\WINDDK\WDF\KMDF10\src\kmdf\apollo
rem call …....\set_wdf_env.cmd

Any more ideas?

Thanks,
Greg

wrote in message news:xxxxx@ntdev…
> Take out the set_wdf_env call. I think the 5600 build includes it
> natively. I had this problem a few days ago!
>
> jorj
>
>

Move your code to a different tree, or (if you will no longer use the previous KMDF + SP1 DDK setup) delete the file C:\winddk\wdf\kmdf10\project.mk.

-----Original Message-----
From: xxxxx@lists.osr.com [mailto:xxxxx@lists.osr.com] On Behalf Of Greg Coleson
Sent: Thursday, October 05, 2006 1:44 PM
To: Windows System Software Devs Interest List
Subject: Re:[ntdev] “obj_path is set for you” error with WDK 5600

That got rid of one error:

BUILD: Compile and Link for x86
1>BUILD: Loading c:\winddk\5600\build.dat…
1>BUILD: Computing Include file dependencies:
1>BUILD: Start time: Thu Oct 05 16:42:07 2006
1>errors in directory c:\winddk\wdf\kmdf10\src\kmdf\apollo
1>obj_path is set for you. You may not set it.
1>BUILD: Examining c:\winddk\wdf\kmdf10\src\kmdf\apollo directory for files
to compile.
1> c:\winddk\wdf\kmdf10\src\kmdf\apollo
1>BUILD: Saving c:\winddk\5600\build.dat…
1>BUILD: Compile errors: not linking c:\winddk\wdf\kmdf10\src\kmdf\apollo
directory
1>BUILD: Finish time: Thu Oct 05 16:42:08 2006
1>BUILD: Done
1> 0 files compiled - 1 Error

The batch file is now:
rem call C:\WINDDK\5308\bin\setenv.bat C:\WINDDK\5308 fre WXP
call C:\WINDDK\5600\bin\setenv.bat C:\WINDDK\5600\ fre WXP
cd C:\WINDDK\WDF\KMDF10\src\kmdf\apollo
rem call …....\set_wdf_env.cmd

Any more ideas?

Thanks,
Greg

wrote in message news:xxxxx@ntdev…
> Take out the set_wdf_env call. I think the 5600 build includes it
> natively. I had this problem a few days ago!
>
> jorj
>
>


Questions? First check the Kernel Driver FAQ at http://www.osronline.com/article.cfm?id=256

To unsubscribe, visit the List Server section of OSR Online at http://www.osronline.com/page.cfm?name=ListServer

Greg Coleson wrote:

That got rid of one error:

BUILD: Compile and Link for x86
1>BUILD: Loading c:\winddk\5600\build.dat…
1>BUILD: Computing Include file dependencies:
1>BUILD: Start time: Thu Oct 05 16:42:07 2006
1>errors in directory c:\winddk\wdf\kmdf10\src\kmdf\apollo
1>obj_path is set for you. You may not set it.
1>BUILD: Examining c:\winddk\wdf\kmdf10\src\kmdf\apollo directory for files
to compile.
1> c:\winddk\wdf\kmdf10\src\kmdf\apollo
1>BUILD: Saving c:\winddk\5600\build.dat…
1>BUILD: Compile errors: not linking c:\winddk\wdf\kmdf10\src\kmdf\apollo
directory
1>BUILD: Finish time: Thu Oct 05 16:42:08 2006
1>BUILD: Done
1> 0 files compiled - 1 Error

The batch file is now:
rem call C:\WINDDK\5308\bin\setenv.bat C:\WINDDK\5308 fre WXP
call C:\WINDDK\5600\bin\setenv.bat C:\WINDDK\5600\ fre WXP
cd C:\WINDDK\WDF\KMDF10\src\kmdf\apollo
rem call …....\set_wdf_env.cmd

Any more ideas?

You’re using the KMDF 1.5 tools with a KMDF 1.0 source. The SOURCES
file is just a bit different. Base your code on \winddk\5600\src\kmdf
instead of \winddk\wdf\kmdf\src\kmdf.


Tim Roberts, xxxxx@probo.com
Providenza & Boekelheide, Inc.