ndistest vs wdk documentation

Having had a complete run through ndistest I’m a little confused by the
results…

NdisTest says:

Variation #5 Check for all required oids
PrintOidName

  • Oid = 0x00010115, OID_GEN_MAXIMUM_SEND_PACKETS
    FAILED: [21478] Supported list does not contain required Oid

While the WDK says of OID_GEN_MAXIMUM_SEND_PACKETS:

Version Information
Windows Vista
Obsolete.
NDIS 6.0 miniport drivers
Obsolete.

Which is correct?

Thanks

James

Haven’t seen that failure on the NDIS driver I am working with here. Don’t
know if your driver is NDIS 6.0 or above but the documentation states that
it is required for NDIS 5.1 I read this as it is obsolete on Vista and
later unless it is an NDIS 5.1 miniport driver.

*Version Information* Windows Vista and later versions of Windows

Obsolete.
NDIS 6.0 and later miniport drivers

Obsolete.
NDIS 5.1 miniport drivers

Mandatory.
Windows XP

Supported.
NDIS 5.1 miniport drivers

Mandatory.

Cheers
Faik

On Wed, Jun 29, 2011 at 11:05 AM, James Harper <
xxxxx@bendigoit.com.au> wrote:

Having had a complete run through ndistest I’m a little confused by the
results…

NdisTest says:

Variation #5 Check for all required oids
PrintOidName

  • Oid = 0x00010115, OID_GEN_MAXIMUM_SEND_PACKETS
    FAILED: [21478] Supported list does not contain required Oid

While the WDK says of OID_GEN_MAXIMUM_SEND_PACKETS:

Version Information
Windows Vista
Obsolete.
NDIS 6.0 miniport drivers
Obsolete.

Which is correct?

Thanks

James


NTDEV is sponsored by OSR

For our schedule of WDF, WDM, debugging and other seminars visit:
http://www.osr.com/seminars

To unsubscribe, visit the List Server section of OSR Online at
http://www.osronline.com/page.cfm?name=ListServer