modem driver install

hi,Eliyas:
Thank you for your help.
You told me that xxxxx@micrsoft.com can help me and will email it to me
,I email to him (xxxxx@micrsoft.com and xxxxx@microsoft.com ),but he do
not write back me.
Are you have the updated version of that sample just
for installing modem? or you can get it and email to me?
Thank you very much.
baiyujing

*******
Mr. rohitr:
In ntdev newsgoup,I have some question about setupdi*** api,Mr.“Eliyas
Yakub” < xxxxx@microsoft.com >
tell me that you can help me.
Can you email the updated version of that sample just for installing modem
to me?
Thanks and Reguards!
baiyujing

*****
This is a known issue. We have an updated version of that sample just
for installing modem. Please send email to xxxxx@micrsoft.com and he
will email it to you.


You are currently subscribed to ntdev as: $subst(‘Recip.EmailAddr’)
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com

Hi

I have tried the modem installation with new information (date march
2001 !!!) and now the installation process is successfully.

In the sample code is a little bug.

if ( SetupDiGetSelectedDriver(hdi, pdevData, &drvData)) {
_tprintf(_T(“SetupDiGetSelectedDriver Failed.\n”));

I think better is

if ( ! …)
{
}

Here is the problem, GetLastError() resports always
ERROR_NO_DRIVER_SELECTED. I hope here is no problem
for the system.

My problem is uninstall !!
the normal way like

SetupDiCallClassInstaller(
DIF_REMOVE,
deviceInfoSet,
&deviceInfoData
)

does NOT work. The modem is not removed.

Any suggestion ?

thanks
elli


You are currently subscribed to ntdev as: $subst(‘Recip.EmailAddr’)
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com

How are you selecting the driver, populating the DeviceInfoData structure,
in the first place?

Joe McCloskey
Gamry Instruments, Inc.
xxxxx@gamry.com

-----Original Message-----
From: xxxxx@lists.osr.com
[mailto:xxxxx@lists.osr.com]On Behalf Of Mathias Ellinger
Sent: Thursday, July 05, 2001 4:24 AM
To: NT Developers Interest List
Subject: [ntdev] Re: modem driver install

Hi

I have tried the modem installation with new information (date march
2001 !!!) and now the installation process is successfully.

In the sample code is a little bug.

if ( SetupDiGetSelectedDriver(hdi, pdevData, &drvData)) {
_tprintf(_T(“SetupDiGetSelectedDriver Failed.\n”));

I think better is

if ( ! …)
{
}

Here is the problem, GetLastError() resports always
ERROR_NO_DRIVER_SELECTED. I hope here is no problem
for the system.

My problem is uninstall !!
the normal way like

SetupDiCallClassInstaller(
DIF_REMOVE,
deviceInfoSet,
&deviceInfoData
)

does NOT work. The modem is not removed.

Any suggestion ?

thanks
elli


You are currently subscribed to ntdev as: xxxxx@gamry.com
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com


You are currently subscribed to ntdev as: $subst(‘Recip.EmailAddr’)
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com

Hello

How are you selecting the driver, populating the DeviceInfoData structure,
in the first place?

I use the deviceInfoData from the Enum and search process for
uninstall (like the sample).

elli


You are currently subscribed to ntdev as: $subst(‘Recip.EmailAddr’)
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com