IP forwarding between ethernet interfaces

Dear Gurus,
This is a network configuration problem, which I am sure most of
you
have dealt with at sometime. Here goes

I have

|-------| |-------|
| Host1 | | Host2 |
| NT WS | | NT WS |
|| ||
^ E1^ ^E2
|------------------------------| |-----> ISP

Host 2 has two ethernet interfaces.

  1. connects to Host1
  2. connects to the cable modem that forwards to my ISP

Each of Host2’s interfaces have IP forwarding enabled and
E1 has a fixed IP number from the 192.168.x.x series and no nominated
default gateway
E2 obtains its IP address via DHCP from the ISP which also supplies
its default gateway

Host1 has its default gateway set to E1’s IP

I can readily access the internet, (and Host1), on Host2

From Host1 I cannot reach the internet. Using tracert I can see that
Host2’s E1 is reached and the cable modem lights show that E2 is
forwarding something in sync with the
2 * * * Request timed out.
type messages.

Questions

  1. Should Host1 be able to access the internet via Host2
  2. If yes then what am I missing, bearing in mind that even if
    I specify a known IP address as the gateway for E1 it still
    fails
  3. If no then what must I do to make it possible

Hoping someone is willing to help

TIA

Don Sharp


You are currently subscribed to ntdev as: $subst(‘Recip.EmailAddr’)
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com

The basic configuration is supposed to work.

However, since host2 is not a NAT (Network Address Translator), then
I don’t see how a host on the internet could respond to a 192.168.x.x address,
i.e., perhaps your packet is doing out, the response cannot be routed.

There is a NAT in Win2K server, but if you just want two machines on the
internet with one IP address, its much less headache just to buy the $110 box
that has a NAT built in.

-DH
----- Original Message -----
From: “Don Sharp”
To: “NT Developers Interest List”
Sent: Wednesday, March 28, 2001 9:51 AM
Subject: [ntdev] IP forwarding between ethernet interfaces

> Dear Gurus,
> This is a network configuration problem, which I am sure most of
> you
> have dealt with at sometime. Here goes
>
> I have
>
> |-------| |-------|
> | Host1 | | Host2 |
> | NT WS | | NT WS |
> | | | |
> ^ E1^ ^E2
> |------------------------------| |-----> ISP
>
> Host 2 has two ethernet interfaces.
> 1) connects to Host1
> 2) connects to the cable modem that forwards to my ISP
>
> Each of Host2’s interfaces have IP forwarding enabled and
> E1 has a fixed IP number from the 192.168.x.x series and no nominated
> default gateway
> E2 obtains its IP address via DHCP from the ISP which also supplies
> its default gateway
>
> Host1 has its default gateway set to E1’s IP
>
> I can readily access the internet, (and Host1), on Host2
> >From Host1 I cannot reach the internet. Using tracert I can see that
> Host2’s E1 is reached and the cable modem lights show that E2 is
> forwarding something in sync with the
> 2 * * * Request timed out.
> type messages.
>
> Questions
> 1) Should Host1 be able to access the internet via Host2
> 2) If yes then what am I missing, bearing in mind that even if
> I specify a known IP address as the gateway for E1 it still
> fails
> 3) If no then what must I do to make it possible
>
> Hoping someone is willing to help
>
> TIA
>
> Don Sharp
>
>
> —
> You are currently subscribed to ntdev as: xxxxx@syssoftsol.com
> To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com


You are currently subscribed to ntdev as: $subst(‘Recip.EmailAddr’)
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com

> 1) Should Host1 be able to access the internet via Host2

No. The packet from the Internet to your hosts will not pass unless you will
have a support on it from your ISP.
Otherwise, use some kind of proxy.

Max


You are currently subscribed to ntdev as: $subst(‘Recip.EmailAddr’)
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com

My thanks to Dave and Max.
As I read further into the subject I discovered that you
are both absolutely right! I’ll either configure a Linux box with IP
masquerading or buy a box.

Thanks a lot.

Don Sharp

Dave Harvey wrote:

The basic configuration is supposed to work.

However, since host2 is not a NAT (Network Address Translator), then
I don’t see how a host on the internet could respond to a 192.168.x.x address,
i.e., perhaps your packet is doing out, the response cannot be routed.

There is a NAT in Win2K server, but if you just want two machines on the
internet with one IP address, its much less headache just to buy the $110 box
that has a NAT built in.

-DH
----- Original Message -----
From: “Don Sharp”
> To: “NT Developers Interest List”
> Sent: Wednesday, March 28, 2001 9:51 AM
> Subject: [ntdev] IP forwarding between ethernet interfaces
>
> > Dear Gurus,
> > This is a network configuration problem, which I am sure most of
> > you
> > have dealt with at sometime. Here goes
> >
> > I have
> >
> > |-------| |-------|
> > | Host1 | | Host2 |
> > | NT WS | | NT WS |
> > | | | |
> > ^ E1^ ^E2
> > |------------------------------| |-----> ISP
> >
> > Host 2 has two ethernet interfaces.
> > 1) connects to Host1
> > 2) connects to the cable modem that forwards to my ISP
> >
> > Each of Host2’s interfaces have IP forwarding enabled and
> > E1 has a fixed IP number from the 192.168.x.x series and no nominated
> > default gateway
> > E2 obtains its IP address via DHCP from the ISP which also supplies
> > its default gateway
> >
> > Host1 has its default gateway set to E1’s IP
> >
> > I can readily access the internet, (and Host1), on Host2
> > >From Host1 I cannot reach the internet. Using tracert I can see that
> > Host2’s E1 is reached and the cable modem lights show that E2 is
> > forwarding something in sync with the
> > 2 * * * Request timed out.
> > type messages.
> >
> > Questions
> > 1) Should Host1 be able to access the internet via Host2
> > 2) If yes then what am I missing, bearing in mind that even if
> > I specify a known IP address as the gateway for E1 it still
> > fails
> > 3) If no then what must I do to make it possible
> >
> > Hoping someone is willing to help
> >
> > TIA
> >
> > Don Sharp
> >
> >
> > —
> > You are currently subscribed to ntdev as: xxxxx@syssoftsol.com
> > To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com
>
> —
> You are currently subscribed to ntdev as: xxxxx@iee.org
> To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com


You are currently subscribed to ntdev as: $subst(‘Recip.EmailAddr’)
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com