how to display debug information for sfilter

Hi,

I installed sfilter in Windows XP pro successfully. also I installed the
DebugMon from OSR, however, the debug information is never show in DebugMon,
can anybody tell my why? any alternative method to show debug information?

Thanks.

Bill Deng

Have you built the checked build of sfilter?

Read the docs. There you’ll find information about WinDbg.

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/ddtools/hh/
ddtools/dbgblurb_25bn.asp

----- Original Message -----
From: “Bill Deng”
Newsgroups: ntfsd
To: “File Systems Developers”
Sent: Friday, August 29, 2003 5:09 AM
Subject: [ntfsd] how to display debug information for sfilter

> Hi,
>
> I installed sfilter in Windows XP pro successfully. also I installed the
> DebugMon from OSR, however, the debug information is never show in
DebugMon,
> can anybody tell my why? any alternative method to show debug information?
>
> Thanks.
>
> Bill Deng
>
>
>
> —
> You are currently subscribed to ntfsd as: xxxxx@linkwave.org
> To unsubscribe send a blank email to xxxxx@lists.osr.com

yes, I built the checked build of sfilter.

I include some debug information in IRP_MJ_CREATE dispatch routine, as
below:

KdPrint((“This information is from SfCreate dispatch routine”));

It is supposed to show some debug information in debuger tool. However,
after I start the DebugMon, nothing show in the output window.

It is still a problem to me. can anyone help me with that. Anyway, thank
you, Tobias.

“Tobias” ???:xxxxx@ntfsd…
>
> Have you built the checked build of sfilter?
>
> Read the docs. There you’ll find information about WinDbg.
>
>
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/ddtools/hh/
> ddtools/dbgblurb_25bn.asp
>
> ----- Original Message -----
> From: “Bill Deng”
> Newsgroups: ntfsd
> To: “File Systems Developers”
> Sent: Friday, August 29, 2003 5:09 AM
> Subject: [ntfsd] how to display debug information for sfilter
>
>
> > Hi,
> >
> > I installed sfilter in Windows XP pro successfully. also I installed the
> > DebugMon from OSR, however, the debug information is never show in
> DebugMon,
> > can anybody tell my why? any alternative method to show debug
information?
> >
> > Thanks.
> >
> > Bill Deng
> >
> >
> >
> > —
> > You are currently subscribed to ntfsd as: xxxxx@linkwave.org
> > To unsubscribe send a blank email to xxxxx@lists.osr.com
>
>
>
>