Disabling Driver Signing...A Solution...

FYI: I found a registry key that will prevent those annoying “unsigned
driver” warning dialogs that appear when you install an unsigned driver.
Just change the following reg key: (Its set to “Policy”=hex:01 by default)

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Driver Signing]
“Policy”=hex:00,00,00,00

Mike


You are currently subscribed to ntdev as: $subst(‘Recip.EmailAddr’)
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com

Or, you could always use the UI:
My Computer
Properties
Hardware
Driver Signing
Ignore/warn/block

Regards,

Paul Bunn, UltraBac.com, 425-644-6000
Microsoft MVP - WindowsNT/2000
http://www.ultrabac.com

-----Original Message-----
From: Weaver, Mike [mailto:xxxxx@CrystalVoice.com]
Sent: Friday, March 30, 2001 5:22 PM
To: NT Developers Interest List
Subject: [ntdev] Disabling Driver Signing…A Solution…

FYI: I found a registry key that will prevent those annoying “unsigned
driver” warning dialogs that appear when you install an unsigned driver.
Just change the following reg key: (Its set to “Policy”=hex:01 by default)

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Driver Signing]
“Policy”=hex:00,00,00,00


You are currently subscribed to ntdev as: $subst(‘Recip.EmailAddr’)
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com

But I remember that Windows restore this key after
restart computer
Mark

“Weaver, Mike” wrote:

FYI: I found a registry key that will prevent those annoying “unsigned
driver” warning dialogs that appear when you install an unsigned driver.
Just change the following reg key: (Its set to “Policy”=hex:01 by default)

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Driver Signing]
“Policy”=hex:00,00,00,00

Mike


You are currently subscribed to ntdev as: xxxxx@arx.com
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com


You are currently subscribed to ntdev as: $subst(‘Recip.EmailAddr’)
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com

It didn’t appear to restore the key after rebooting on my system. In
addition, I only intend to change the key temporarily, while I install my
driver on the users system.

Mike

-----Original Message-----
From: Mark Shnaider [mailto:xxxxx@arx.com]
Sent: Sunday, April 01, 2001 4:49 AM
To: NT Developers Interest List
Subject: [ntdev] Re: Disabling Driver Signing…A Solution…

But I remember that Windows restore this key after
restart computer
Mark

“Weaver, Mike” wrote:

FYI: I found a registry key that will prevent those annoying “unsigned
driver” warning dialogs that appear when you install an unsigned driver.
Just change the following reg key: (Its set to “Policy”=hex:01 by
default)

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Driver Signing]
“Policy”=hex:00,00,00,00

Mike


You are currently subscribed to ntdev as: xxxxx@arx.com
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com


You are currently subscribed to ntdev as: xxxxx@crystalvoice.com
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com


You are currently subscribed to ntdev as: $subst(‘Recip.EmailAddr’)
To unsubscribe send a blank email to leave-ntdev-$subst(‘Recip.MemberIDChar’)@lists.osr.com