Windows System Software -- Consulting, Training, Development -- Unique Expertise, Guaranteed Results

Before Posting...
Please check out the Community Guidelines in the Announcements and Administration Category.

Some new windbg weirdness

matt_sykesmatt_sykes Member - All Emails Posts: 270

This was working OK, but I had to switch some machines around. Use the target as a host for a day, and then trying to run it as a target, back in the original configuration, and it falls off the debugger. Every single time:

Connected to target
You can get the target MAC address by running .kdtargetmac command.
Connected to Windows 10 14393 x64 target at (Wed Jan 30 14:16:18.994 2019 (UTC + 0:00)), ptr64 TRUE
Kernel Debugger connection established.

************* Path validation summary **************
Response Time (ms) Location
OK D:\Scuf\Driver\objchk_win7_amd64\amd64
Deferred srvd:\pdbfileshttp://msdl.microsoft.com/download/symbols
Symbol search path is: D:\Scuf\Driver\objchk_win7_amd64\amd64;srvd:\pdbfileshttp://msdl.microsoft.com/download/symbols
Executable search path is:
Windows 10 Kernel Version 14393 MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 14393.2068.amd64fre.rs1_release.180209-1727
Machine Name:
Kernel base = 0xfffff8008f088000 PsLoadedModuleList = 0xfffff8008f3901a0
Debug session time: Wed Jan 30 14:18:00.262 2019 (UTC + 0:00)
System Uptime: 0 days 0:00:05.020
KDTARGET: Refreshing KD connection
+++++>WskKnrPodCreate.

The target then hangs for a number of seconds, then falls off the debugger and boots.

Bit of a pain really.

Comments

  • matt_sykesmatt_sykes Member - All Emails Posts: 270

    Switched to a different target and I have the same issue. So it looks like the host.

    It had a problem recently, the SSD (which had the C: partition on it) went out to lunch late monday, got it back by creating an EFI partition, and making it the MBR and giving it the windows 7 (on a different disk) as the boot OS. (Windows 7 as the host was what I was using last week, and it was OK) so what might possible have got screwed up in losing windows 10, which was on the SSD? Does windbg have any hard dependencies on stuff in the C: drive?

  • matt_sykesmatt_sykes Member - All Emails Posts: 270

    OK, so I installed WIndows 10 on the C drive on the host. Exactly the same error and trace.

    Dont forget, before the SSD drive lost the plot this worked OK with windows 7 as the host.

    Next I I swapped the host and target around, and it debugs OK, and I dont get the +++++>WskKnrPodCreate trace.

    I googled it, but nothing came up, does anyone know what this is?

    It all seems a bit random to me, but one set of events stands out: Why would an SSD drive crash interfere with the hardware's ability to act as a host debugger?

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Upcoming OSR Seminars
Developing Minifilters 29 July 2019 OSR Seminar Space
Writing WDF Drivers 23 Sept 2019 OSR Seminar Space
Kernel Debugging 21 Oct 2019 OSR Seminar Space
Internals & Software Drivers 18 Nov 2019 Dulles, VA