Windows System Software -- Consulting, Training, Development -- Unique Expertise, Guaranteed Results

Sept/Oct 2019 Issue of The NT Insider available


Download PDF here: http://insider.osr.com/2019/ntinsider_2019_01.pdf

It’s a particularly BIG issue, too: 40 pages of technical goodness, ranging from WDF to Minifilters. Check it out.
Before Posting...
Please check out the Community Guidelines in the Announcements and Administration Category.

WinDbg error - waiting to reconnect

Hi,

I am a newbie in Kernel mode debugging. I am trying to setup a debug
environment to debug a intermediate driver using a null model cable
connection.

The target system and host system are running windows 2000 professional. I
have configured my target system to start in debug mode by adding the
/debug /debugport=com1 /baudrate=9600 in the boot.ini file. The Host system
is running WinDbg 6.5.0003.7.

When I am enabing kernel mode debugging on com1 port and baudrate=9600, the
windbg shows a message in the connect window "opened \\. \com1 waiting
to reconnect" and in the status bar, "debuggee not connected " message.

I have tested the null modem connection between host and target system using
hyperterminal.

Can someone please help me to solve this problem.

Thank you all in advance.
-Niranjan

Comments

  • OSR_Community_UserOSR_Community_User Member Posts: 110,217
    Try:

    1) Debug/Kernel Connection/Resynchronize from WinDbg while the target
    machine is running

    Or

    2) Restart the target machine while WinDbg is up.





    -----Original Message-----
    From: xxxxx@lists.osr.com
    [mailto:xxxxx@lists.osr.com] On Behalf Of Niranjan
    Sent: Wednesday, September 14, 2005 12:29 PM
    To: Kernel Debugging Interest List
    Subject: [windbg] WinDbg error - waiting to reconnect

    Hi,

    I am a newbie in Kernel mode debugging. I am trying to setup a debug
    environment to debug a intermediate driver using a null model cable
    connection.

    The target system and host system are running windows 2000 professional. I
    have configured my target system to start in debug mode by adding the
    /debug /debugport=com1 /baudrate=9600 in the boot.ini file. The Host system
    is running WinDbg 6.5.0003.7.

    When I am enabing kernel mode debugging on com1 port and baudrate=9600, the
    windbg shows a message in the connect window "opened \\. \com1 waiting
    to reconnect" and in the status bar, "debuggee not connected " message.

    I have tested the null modem connection between host and target system using
    hyperterminal.

    Can someone please help me to solve this problem.

    Thank you all in advance.
    -Niranjan




    ---
    You are currently subscribed to windbg as: xxxxx@yahoo.com
    To unsubscribe send a blank email to xxxxx@lists.osr.com
  • amitr0-2amitr0-2 Member - All Emails Posts: 940
    >The target system and host system are running windows 2000 professional. I
    >have configured my target system to start in debug mode by adding the
    >/debug /debugport=com1 /baudrate=9600 in the boot.ini file. The Host system
    >is running WinDbg 6.5.0003.7 .

    1. 9600 is too slow, use higher settings ( though this has nothing to do
    with your problem, it will save time )

    2. Does the debuggee have a serial mouse or PS2 one? By default debugging is
    enabled in COM2 for the debugee to avoid conflicts with serial mice, try
    changing the port, or even eliminating the /debugport switch and try.

    3. Your host, running windbg should have the cable on COM1 ( though you can
    change the settings thriough the debugger)


    Amitrajit
  • OSR_Community_UserOSR_Community_User Member Posts: 110,217
    Niranjan:

    A few ideas, as I know this problem can be frustrating. Perhaps you already know this, but, as you say you are new to KD, unless you have a very compelling reason to use COM/NULL, I would strongly consider using 1394. It is much, much faster and not much more difficult to use, especially since you are having trouble with COM.

    In any case, I suspect the problem is either that you have no requested an initial breakpoint or, possibly, that you do not have symbols loaded. If either of these is the case, try the following (command lines for both COM and 1394 are included).

    TARGET:

    BOOT.INI

    1394: /debug /debugport=1394 /channel=1 (or /channel=0, et. c.)
    COM: No changes

    1394: Disable the 1394 controller on the target (using Device Manager, for example).

    Reboot.

    HOST:

    Uninstall WinDbg and reinstall it. Make sure that the folder containing WinDbg.EXE is added to your system path (environment variables on the advanced tab of computer properties). Reboot.

    Start WinDbg with the following command line (or connect from in WinDbg with these options).

    1394: WinDbg -k 1394:channel=X -b -ysrv*LOCAL_SYMBOL_STORE*http://msdl.microsoft.com/download/symbols

    WHERE:

    -channel=X -> X is the same chanell number you set in Boot.INI

    LOCAL_SYMBOL_STORE is the fullpath of a folder to use a local symbol folder. If you don't have one or don't know what this is, it can be any folder on your computer. Just pick one that has nothing else in it.

    -OR-

    COM: Add -b to your existing command line.

    If you still are not seeing output in the command window (WinDbg), try pressing Ctrl+Break or selecting the "Break" item from the "Debug" menu.

    I hope this helps. If it does not, and you don't find the answer elsewhere, please send me the command line you are using for WinDbg.

    MM


    >>> xxxxx@sta.samsung.com 09/14/05 3:28 PM >>>
    Hi,

    I am a newbie in Kernel mode debugging. I am trying to setup a debug
    environment to debug a intermediate driver using a null model cable
    connection.

    The target system and host system are running windows 2000 professional. I
    have configured my target system to start in debug mode by adding the
    /debug /debugport=com1 /baudrate=9600 in the boot.ini file. The Host system
    is running WinDbg 6.5.0003.7.

    When I am enabing kernel mode debugging on com1 port and baudrate=9600, the
    windbg shows a message in the connect window "opened \\. \com1 waiting
    to reconnect" and in the status bar, "debuggee not connected " message.

    I have tested the null modem connection between host and target system using
    hyperterminal.

    Can someone please help me to solve this problem.

    Thank you all in advance.
    -Niranjan




    ---
    You are currently subscribed to windbg as: xxxxx@evitechnology.com
    To unsubscribe send a blank email to xxxxx@lists.osr.com
  • Thanks for the reply.

    Debuggee has a PS2 mouse. The cables are connected correctly as I have tested it using hyperterminal with both system configured on COM1 and baud rate of 19200. I tried changing the boot.ini file but it didn't work.

    Is there any other configuration which I am missing or any other way to debug the networking drivers on Windows 2000 systerm? Also, do I need a debug image on the target system or the host system for the connection?

    Thanks,
    -Niranjan
    "Developer" wrote in message news:xxxxx@windbg...

    >The target system and host system are running windows 2000 professional. I
    >have configured my target system to start in debug mode by adding the
    >/debug /debugport=com1 /baudrate=9600 in the boot.ini file. The Host system
    >is running WinDbg 6.5.0003.7.

    1. 9600 is too slow, use higher settings ( though this has nothing to do with your problem, it will save time )

    2. Does the debuggee have a serial mouse or PS2 one? By default debugging is enabled in COM2 for the debugee to avoid conflicts with serial mice, try changing the port, or even eliminating the /debugport switch and try.

    3. Your host, running windbg should have the cable on COM1 ( though you can change the settings thriough the debugger)


    Amitrajit
  • amitr0-2amitr0-2 Member - All Emails Posts: 940
    >Thanks for the reply.
    >Debuggee has a PS2 mouse. The cables are connected correctly as I have
    tested it using >hyperterminal with both system configured on COM1 and baud
    rate of 19200.

    So you mean, you were able to communicate bidirectionally with
    Hyperterminal?


    >I tried changing the >boot.ini file but it didn't work.
    >Is there any other configuration which I am missing or any other way to
    debug the networking >drivers on Windows 2000 systerm?
    Have you read sysinternals articls on this, google it you will find
    information.


    > Also, do I need a debug image on the target system or the host >system for
    the connection?

    What do you mean by debug image? Do you mean checked build?

    Your driver needs to run on the debugee, and the symbols of the debugee
    needs to be loaded on the host (hope you know how to get the correct debug
    symbols? ) Is that what you are asking?
  • Yes. The host and target system are able to communicate bidirectionally with Hyperterminal. I have read the documentation on Windows MSDN.

    By debug image, I mean checked build. Now, both the system is running free build and I have installed windows 2000 symbols and sp4 symbols on the host system.

    Thanks,
    -Niranjan
    "Developer" wrote in message news:xxxxx@windbg...
    >Thanks for the reply.

    >Debuggee has a PS2 mouse. The cables are connected correctly as I have tested it using >hyperterminal with both system configured on COM1 and baud rate of 19200.

    So you mean, you were able to communicate bidirectionally with Hyperterminal?


    >I tried changing the >boot.ini file but it didn't work.

    >Is there any other configuration which I am missing or any other way to debug the networking >drivers on Windows 2000 systerm?
    Have you read sysinternals articls on this, google it you will find information.


    > Also, do I need a debug image on the target system or the host >system for the connection?

    What do you mean by debug image? Do you mean checked build?

    Your driver needs to run on the debugee, and the symbols of the debugee needs to be loaded on the host (hope you know how to get the correct debug symbols? ) Is that what you are asking?
  • OSR_Community_UserOSR_Community_User Member Posts: 110,217
    Press ctrl+d (or ctrl+alt+d, if using WinDbg), then boot the
    target system. Is there any debug spew coming out of kd/windbg?



    Jason



    ________________________________

    From: xxxxx@lists.osr.com
    [mailto:xxxxx@lists.osr.com] On Behalf Of Niranjan
    Sent: Thursday, September 15, 2005 9:25 AM
    To: Kernel Debugging Interest List
    Subject: Re:[windbg] WinDbg error - waiting to reconnect



    Yes. The host and target system are able to communicate bidirectionally
    with Hyperterminal. I have read the documentation on Windows MSDN.



    By debug image, I mean checked build. Now, both the system is running
    free build and I have installed windows 2000 symbols and sp4 symbols on
    the host system.



    Thanks,

    -Niranjan

    "Developer" wrote in message
    news:xxxxx@windbg...

    >Thanks for the reply.



    >Debuggee has a PS2 mouse. The cables are connected correctly as
    I have tested it using >hyperterminal with both system configured on
    COM1 and baud rate of 19200.

    So you mean, you were able to communicate bidirectionally with
    Hyperterminal?


    >I tried changing the >boot.ini file but it didn't work.

    >Is there any other configuration which I am missing or any
    other way to debug the networking >drivers on Windows 2000 systerm?
    Have you read sysinternals articls on this, google it you will
    find information.


    > Also, do I need a debug image on the target system or the host
    >system for the connection?

    What do you mean by debug image? Do you mean checked build?

    Your driver needs to run on the debugee, and the symbols of the
    debugee needs to be loaded on the host (hope you know how to get the
    correct debug symbols? ) Is that what you are asking?


    ---
    You are currently subscribed to windbg as: unknown lmsubst tag argument:
    ''
    To unsubscribe send a blank email to xxxxx@lists.osr.com
  • I am working on Windows 2000 system and I think debugging using 1394 is not
    supported on this version.

    I will try doing the whole process again. But I have 1 question before that.
    Isn't the symbol loading or breakpoing setting done after the debugger is
    connected to the target system?

    Thanks,
    -Niranjan

    "Martin O'Brien" wrote in message
    news:xxxxx@windbg...
    Niranjan:

    A few ideas, as I know this problem can be frustrating. Perhaps you already
    know this, but, as you say you are new to KD, unless you have a very
    compelling reason to use COM/NULL, I would strongly consider using 1394. It
    is much, much faster and not much more difficult to use, especially since
    you are having trouble with COM.

    In any case, I suspect the problem is either that you have no requested an
    initial breakpoint or, possibly, that you do not have symbols loaded. If
    either of these is the case, try the following (command lines for both COM
    and 1394 are included).

    TARGET:

    BOOT.INI

    1394: /debug /debugport=1394 /channel=1 (or /channel=0, et. c.)
    COM: No changes

    1394: Disable the 1394 controller on the target (using Device Manager, for
    example).

    Reboot.

    HOST:

    Uninstall WinDbg and reinstall it. Make sure that the folder containing
    WinDbg.EXE is added to your system path (environment variables on the
    advanced tab of computer properties). Reboot.

    Start WinDbg with the following command line (or connect from in WinDbg with
    these options).

    1394: WinDbg -k
    1394:channel=X -b -ysrv*LOCAL_SYMBOL_STORE*http://msdl.microsoft.com/downloa
    d/symbols

    WHERE:

    -channel=X -> X is the same chanell number you set in Boot.INI

    LOCAL_SYMBOL_STORE is the fullpath of a folder to use a local symbol folder.
    If you don't have one or don't know what this is, it can be any folder on
    your computer. Just pick one that has nothing else in it.

    -OR-

    COM: Add -b to your existing command line.

    If you still are not seeing output in the command window (WinDbg), try
    pressing Ctrl+Break or selecting the "Break" item from the "Debug" menu.

    I hope this helps. If it does not, and you don't find the answer elsewhere,
    please send me the command line you are using for WinDbg.

    MM


    >>> xxxxx@sta.samsung.com 09/14/05 3:28 PM >>>
    Hi,

    I am a newbie in Kernel mode debugging. I am trying to setup a debug
    environment to debug a intermediate driver using a null model cable
    connection.

    The target system and host system are running windows 2000 professional. I
    have configured my target system to start in debug mode by adding the
    /debug /debugport=com1 /baudrate=9600 in the boot.ini file. The Host system
    is running WinDbg 6.5.0003.7.

    When I am enabing kernel mode debugging on com1 port and baudrate=9600, the
    windbg shows a message in the connect window "opened \\. \com1 waiting
    to reconnect" and in the status bar, "debuggee not connected " message.

    I have tested the null modem connection between host and target system using
    hyperterminal.

    Can someone please help me to solve this problem.

    Thank you all in advance.
    -Niranjan




    ---
    You are currently subscribed to windbg as: xxxxx@evitechnology.com
    To unsubscribe send a blank email to xxxxx@lists.osr.com
  • Gary_LittleGary_Little Member Posts: 335
    Are you by any chance using USB to serial on the host? If so, don't, or drop
    your bps to 2400 or slower. If you have a REAL serial port on the host then
    do a break, or set an initial break point using Ctl+Alt+K. Once the target
    responds, reboot and jack the bps up to at least 115.2K. You will NOT like
    the debugger at 9600 bps.

    --
    The personal opinion of
    Gary G. Little


    "Niranjan" wrote in message news:xxxxx@windbg...
    > Hi,
    >
    > I am a newbie in Kernel mode debugging. I am trying to setup a debug
    > environment to debug a intermediate driver using a null model cable
    > connection.
    >
    > The target system and host system are running windows 2000 professional.
    > I
    > have configured my target system to start in debug mode by adding the
    > /debug /debugport=com1 /baudrate=9600 in the boot.ini file. The Host
    > system
    > is running WinDbg 6.5.0003.7.
    >
    > When I am enabing kernel mode debugging on com1 port and baudrate=9600,
    > the
    > windbg shows a message in the connect window "opened \\. \com1 waiting
    > to reconnect" and in the status bar, "debuggee not connected " message.
    >
    > I have tested the null modem connection between host and target system
    > using
    > hyperterminal.
    >
    > Can someone please help me to solve this problem.
    >
    > Thank you all in advance.
    > -Niranjan
    >
    >
    >
    >
  • OSR_Community_UserOSR_Community_User Member Posts: 110,217
    Hello Niranjan,
    First up, if they can communicate bidirectionally with
    hypertrm, you must have turned the boot.ini switches off & rebooted
    first, right? Otherwise you're plugged into the wrong COM port on the
    target. Sometimes what the case labels as COM1 is really COM2... Next
    you should look at the target's BIOS and disable legacy USB support, if
    there is an option for it. If this doesn't fix it, you should send
    output from windbg of the following commands:

    Ctrl+Alt+D

    Ctrl+Alt+R

    Ctrl+Break


    Thanks,
    Jason

    ________________________________

    From: xxxxx@lists.osr.com
    [mailto:xxxxx@lists.osr.com] On Behalf Of Niranjan
    Sent: Thursday, September 15, 2005 9:25 AM
    To: Kernel Debugging Interest List
    Subject: Re:[windbg] WinDbg error - waiting to reconnect

    Yes. The host and target system are able to communicate bidirectionally
    with Hyperterminal. I have read the documentation on Windows MSDN.

    By debug image, I mean checked build. Now, both the system is running
    free build and I have installed windows 2000 symbols and sp4 symbols on
    the host system.

    Thanks,
    -Niranjan
    "Developer" wrote in message
    news:xxxxx@windbg...
    >Thanks for the reply.

    >Debuggee has a PS2 mouse. The cables are connected correctly as
    I have tested it using >hyperterminal with both system configured on
    COM1 and baud rate of 19200.

    So you mean, you were able to communicate bidirectionally with
    Hyperterminal?


    >I tried changing the >boot.ini file but it didn't work.
    >Is there any other configuration which I am missing or any
    other way to debug the networking >drivers on Windows 2000 systerm?
    Have you read sysinternals articls on this, google it you will
    find information.


    > Also, do I need a debug image on the target system or the host
    >system for the connection?

    What do you mean by debug image? Do you mean checked build?

    Your driver needs to run on the debugee, and the symbols of the
    debugee needs to be loaded on the host (hope you know how to get the
    correct debug symbols? ) Is that what you are asking?

    ---
    You are currently subscribed to windbg as: unknown lmsubst tag argument:
    ''
    To unsubscribe send a blank email to xxxxx@lists.osr.com
  • I got the WinDbg running. I did everything from the beginning again and it works this time.

    Thanks for your help and time.

    -Niranjan

    "Jason Cunningham" wrote in message news:xxxxx@windbg...
    Hello Niranjan,

    First up, if they can communicate bidirectionally with hypertrm, you must have turned the boot.ini switches off & rebooted first, right? Otherwise you're plugged into the wrong COM port on the target. Sometimes what the case labels as COM1 is really COM2. Next you should look at the target's BIOS and disable legacy USB support, if there is an option for it. If this doesn't fix it, you should send output from windbg of the following commands:



    Ctrl+Alt+D



    Ctrl+Alt+R



    Ctrl+Break





    Thanks,

    Jason




    ------------------------------------------------------------------------------

    From: xxxxx@lists.osr.com [mailto:xxxxx@lists.osr.com] On Behalf Of Niranjan
    Sent: Thursday, September 15, 2005 9:25 AM
    To: Kernel Debugging Interest List
    Subject: Re:[windbg] WinDbg error - waiting to reconnect



    Yes. The host and target system are able to communicate bidirectionally with Hyperterminal. I have read the documentation on Windows MSDN.



    By debug image, I mean checked build. Now, both the system is running free build and I have installed windows 2000 symbols and sp4 symbols on the host system.



    Thanks,

    -Niranjan

    "Developer" wrote in message news:xxxxx@windbg...

    >Thanks for the reply.



    >Debuggee has a PS2 mouse. The cables are connected correctly as I have tested it using >hyperterminal with both system configured on COM1 and baud rate of 19200.

    So you mean, you were able to communicate bidirectionally with Hyperterminal?


    >I tried changing the >boot.ini file but it didn't work.

    >Is there any other configuration which I am missing or any other way to debug the networking >drivers on Windows 2000 systerm?
    Have you read sysinternals articls on this, google it you will find information.


    > Also, do I need a debug image on the target system or the host >system for the connection?

    What do you mean by debug image? Do you mean checked build?

    Your driver needs to run on the debugee, and the symbols of the debugee needs to be loaded on the host (hope you know how to get the correct debug symbols? ) Is that what you are asking?


    ---
    You are currently subscribed to windbg as: unknown lmsubst tag argument: ''
    To unsubscribe send a blank email to xxxxx@lists.osr.com
  • OSR_Community_UserOSR_Community_User Member Posts: 110,217
    Yes, it is. I doubt that it is the problem (actually, like you, I don't
    see how it could be), but I have seen lack of symbols or incorrect
    symbol path cause all sorts of bizare errors that would, by any
    reasonable standard, appear to be unrealted to symbols.

    MM


    >>> xxxxx@sta.samsung.com 09/15/05 12:37 PM >>>
    I am working on Windows 2000 system and I think debugging using 1394 is
    not
    supported on this version.

    I will try doing the whole process again. But I have 1 question before
    that.
    Isn't the symbol loading or breakpoing setting done after the debugger
    is
    connected to the target system?

    Thanks,
    -Niranjan

    "Martin O'Brien" <xxxxx@evitechnology.com> wrote in message
    news:xxxxx@windbg...
    Niranjan:

    A few ideas, as I know this problem can be frustrating. Perhaps you
    already
    know this, but, as you say you are new to KD, unless you have a very
    compelling reason to use COM/NULL, I would strongly consider using
    1394. It
    is much, much faster and not much more difficult to use, especially
    since
    you are having trouble with COM.

    In any case, I suspect the problem is either that you have no requested
    an
    initial breakpoint or, possibly, that you do not have symbols loaded.
    If
    either of these is the case, try the following (command lines for both
    COM
    and 1394 are included).

    TARGET:

    BOOT.INI

    1394: /debug /debugport=1394 /channel=1 (or /channel=0, et. c.)
    COM: No changes

    1394: Disable the 1394 controller on the target (using Device Manager,
    for
    example).

    Reboot.

    HOST:

    Uninstall WinDbg and reinstall it. Make sure that the folder
    containing
    WinDbg.EXE is added to your system path (environment variables on the
    advanced tab of computer properties). Reboot.

    Start WinDbg with the following command line (or connect from in WinDbg
    with
    these options).

    1394: WinDbg -k
    1394:channel=X -b
    -ysrv*LOCAL_SYMBOL_STORE*http://msdl.microsoft.com/downloa
    d/symbols

    WHERE:

    -channel=X -> X is the same chanell number you set in Boot.INI

    LOCAL_SYMBOL_STORE is the fullpath of a folder to use a local symbol
    folder.
    If you don't have one or don't know what this is, it can be any folder
    on
    your computer. Just pick one that has nothing else in it.

    -OR-

    COM: Add -b to your existing command line.

    If you still are not seeing output in the command window (WinDbg), try
    pressing Ctrl+Break or selecting the "Break" item from the "Debug"
    menu.

    I hope this helps. If it does not, and you don't find the answer
    elsewhere,
    please send me the command line you are using for WinDbg.

    MM


    >>> xxxxx@sta.samsung.com 09/14/05 3:28 PM >>>
    Hi,

    I am a newbie in Kernel mode debugging. I am trying to setup a debug
    environment to debug a intermediate driver using a null model cable
    connection.

    The target system and host system are running windows 2000
    professional. I
    have configured my target system to start in debug mode by adding the
    /debug /debugport=com1 /baudrate=9600 in the boot.ini file. The Host
    system
    is running WinDbg 6.5.0003.7.

    When I am enabing kernel mode debugging on com1 port and baudrate=9600,
    the
    windbg shows a message in the connect window "opened \\. \com1 waiting
    to reconnect" and in the status bar, "debuggee not connected "
    message.

    I have tested the null modem connection between host and target system
    using
    hyperterminal.

    Can someone please help me to solve this problem.

    Thank you all in advance.
    -Niranjan




    ---
    You are currently subscribed to windbg as: xxxxx@evitechnology.com
    To unsubscribe send a blank email to xxxxx@lists.osr.com





    ---
    You are currently subscribed to windbg as: xxxxx@evitechnology.com
    To unsubscribe send a blank email to xxxxx@lists.osr.com
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Upcoming OSR Seminars
Writing WDF Drivers 21 Oct 2019 OSR Seminar Space & ONLINE
Internals & Software Drivers 18 Nov 2019 Dulles, VA
Kernel Debugging 30 Mar 2020 OSR Seminar Space
Developing Minifilters 27 Apr 2020 OSR Seminar Space & ONLINE