Windows System Software -- Consulting, Training, Development -- Unique Expertise, Guaranteed Results

Before Posting...
Please check out the Community Guidelines in the Announcements and Administration Category.

More Info on Driver Writing and Debugging

The free OSR Learning Library has more than 50 articles on a wide variety of topics about writing and debugging device drivers and Minifilters. From introductory level to advanced. All the articles have been recently reviewed and updated, and are written using the clear and definitive style you've come to expect from OSR over the years.

Check out The OSR Learning Library at:

Not able to open Virtual COM port in some of the Serial Terminals like YAT and SerialMon

vinayforblogvinayforblog Member Posts: 2


I have developed a Windows Virtual COM Port driver based on UMDF 2.15. I am able to open the COM port via some of the well known terminals like Putty, Hyperterminal, Tera-Term, CoolTerm, RealTerm and XCTU. But if I try to open the terminal through some of the terminals like SerialMon and YAT I will get the following error.

**The given port name does not start with COM/com or does not resolve to a valid serial port.

Parameter name: portName
I have also checked in Windows Registry Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\ROOT\PORTS that whether the the Virtual COM port is registered properly or not. Under Device parameters I could able to see a key PortName with COM port number. Also COM port is registered in the path Computer\HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\SERIALCOMM . I tried installing the driver on COM port number more than 9 (i.e on COM10, COM11 etc) but same error came.

My questions are,

1) If other terminals are able to open the port then what is the problem with these terminals?

2) Is the port name key is case sensitive? The error I am getting in these terminals has 'portName' whereas the key registered on the windows registry has 'PortName' with p as upper case. Could it be a problem? I changed some code in driver after creating symbolic link to change the key name to lower case p. But It did not work.

3) Since it is a Virtual Port those terminals are not able to open it?? Do they support only physical port??

Please help me to solve this issue.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Upcoming OSR Seminars
OSR has suspended in-person seminars due to the Covid-19 outbreak. But, don't miss your training! Attend via the internet instead!
Writing WDF Drivers 7 Dec 2020 LIVE ONLINE
Internals & Software Drivers 25 Jan 2021 LIVE ONLINE
Developing Minifilters 8 March 2021 LIVE ONLINE