Windows System Software -- Consulting, Training, Development -- Unique Expertise, Guaranteed Results

Before Posting...
Please check out the Community Guidelines in the Announcements and Administration Category.

More Info on Driver Writing and Debugging


The free OSR Learning Library has more than 50 articles on a wide variety of topics about writing and debugging device drivers and Minifilters. From introductory level to advanced. All the articles have been recently reviewed and updated, and are written using the clear and definitive style you've come to expect from OSR over the years.


Check out The OSR Learning Library at: https://www.osr.com/osr-learning-library/


WinDbg so slow it's nearly unusable?

David_F.David_F. Member Posts: 198

Hi,

This problem has been going on now for a year at least, prior to that, it always worked well. I had been using Win7 and problem existed, now on Win10, same thing. Using VirtualBox and pipe to connect. Same issue with WinDbg Preview as well (although didn't seem as bad). This session this time being Win10 on vm, but happens with others, connects, blue window icon shows, and windbg has the "System Uptime: 0 days 0:00:00:000" and then it sits there for 15 minutes doing nothing, everytime. I emptied my local symbol cache, i had only loaded in ntkrnlmp.pdb in that entire time so doesn't seem to have to do with symbol store. Once it starts going, it goes normal speed. Using Norton 360, but think issue also occurred back when using BitDefender.

Now on top of that, I have problem trying to set break points, I pull up my source, can even hover over and see symbols/structure information, but trying to set a break point via the hand doesn't work, it either spins for several minutes (note symbol cache growing) then says it can't find it or sets it to 0 right away, depending on the source module. lm shows the driver is there with private symbols. Spent 3 hours on this now for something I thought would take about 5 min to find / fix, but haven't even been able to get to it. argh!

Any suggestions?

TIA!!

Comments

  • David_F.David_F. Member Posts: 198

    Used x mydriver! and missing lots of symbols, so I gave up on the release version, went to a debug version, now I was able to set a break point. But, trying to use F10 for step over, 1 to 3 minutes per step. BUSY - Disassembly saying retrieving information... Then that comes up, and you may have to wait a while as it goes to BUSY Debuggee is running. OMG! What is going on? How do I fix it?

    TIA!!

  • David_F.David_F. Member Posts: 198

    HOORAY!! I moved over to NET instead of PIPE and now it's usable!! Thank Goodness. There is something in this new WinDbg Preview that offers a "Target" field for the "Net" option but it doesn't tell you anywhere (including help) what the "target" should be. I gave up and left it blank and it worked... good enough for me.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Upcoming OSR Seminars
OSR has suspended in-person seminars due to the Covid-19 outbreak. But, don't miss your training! Attend via the internet instead!
Kernel Debugging 30 Mar 2020 OSR Seminar Space
Developing Minifilters 15 Jun 2020 LIVE ONLINE
Writing WDF Drivers 22 June 2020 LIVE ONLINE
Internals & Software Drivers 28 Sept 2020 Dulles, VA