Windows System Software -- Consulting, Training, Development -- Unique Expertise, Guaranteed Results

Before Posting...
Please check out the Community Guidelines in the Announcements and Administration Category.

StorPortEnablePassiveInitialization is not working

Muthazhagan_ArulbalasubramaniMuthazhagan_Arulbalasubramani Member - All Emails Posts: 16
Hi All,

I am developing a Storport Miniport driver, and I came across a strange problem today.

I have below sample routines:

HwInit(){
StorPortEnablePassiveInitialization(PassiveInit);
}

PassiveInit(){
//DPC initialization
}

HwStorAdapterControl(){
ScsiQuerySupportedControlTypes:
SCSI_STOP_ADAPTER
//I have registered only SCSI_STOP_ADAPTER.
}
I installed the driver, driverentry -> FindAdapter -> HwInit -> PassiveInit -> AdapterControl Executed in Sequence. Driver successfully installed.

Then I did a Power Off(Cold) and Powerd On the PC, Since I didn't register ScsiRestartAdapter in adapter power control routine, I was expecting Findadapter, hwinit,and PassiveInit to be called. But the strange part is only Findadapter and HwInit was getting called not PassiveInit().

Eventhough StorPortEnablePassiveInitialization(PassiveInit) was returing TRUE. still PassiveInit was not getting called.

Any suggestion would be helpful.

Thanks in advance,
Muthu
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Upcoming OSR Seminars
Developing Minifilters 29 July 2019 OSR Seminar Space
Writing WDF Drivers 23 Sept 2019 OSR Seminar Space
Kernel Debugging 21 Oct 2019 OSR Seminar Space
Internals & Software Drivers 18 Nov 2019 Dulles, VA