Windows System Software -- Consulting, Training, Development -- Unique Expertise, Guaranteed Results

Before Posting...
Please check out the Community Guidelines in the Announcements and Administration Category.

Visual Studio is looking for wrong version of the WDK.

Michael_RolleMichael_Rolle Member - All Emails Posts: 135

I've installed WDK 10.17763 with the Visual Studio extension. However, the stampinf step in the driver project build is looking for stampinf.exe in the 17134.0 location. This comes from the macro $(WDKBinRoot), which is part of the Executable Directories property for the project.
I'd like to know where these macro values are stored so that I can change them. The 17763 install presumably should have taken care of this, but it did not.
Other steps in the driver build might also suffer the same problem.
Happy New Year everyone.
Oh yes, doing Retarget Projects in VS doesn't offer any WDK versions, only SDK versions. So maybe my WDK install went wrong?

Comments

  • CymonCymon Member Posts: 4

    The WDK set this based on WindowsSdkDir so it should be auto-updated. Was the new SDK installed prior to the new WDK being installed?

  • Michael_RolleMichael_Rolle Member - All Emails Posts: 135

    I discovered the SDK Version setting under my project's properties General page. When I set this to the SDK version, the various WDK macros followed suit automatically

  • SoLaRSoLaR Member Posts: 15

    Yes I discovered this a month ago (not sure if I have reported it to MS).
    But quickest way to fix issue after this VS/WDK update was to downgrade SDK/WDK to 10.0.17134.0 by changing project settings to use specific SDK/WDK version instead of latest's version:

    Please notice if you have both kernel/user driver and driver application both project properties should be changed to use same "Windows SDK Version":

    Visual Studio 2017 > Project Settings (Property Pages) > Configuration Properties > General
    Set "Windows SDK Version" : "10.0.17134.0"

    And build, it should build just fine.

    PS: platform tools set is responsible for WDK builds, so in kernel driver project settings you should have it set to "WindowsKernelModeDriver10.0", and configuration type to "Driver".

    hope this helps

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Upcoming OSR Seminars
Developing Minifilters 29 July 2019 OSR Seminar Space
Writing WDF Drivers 23 Sept 2019 OSR Seminar Space
Kernel Debugging 21 Oct 2019 OSR Seminar Space
Internals & Software Drivers 18 Nov 2019 Dulles, VA