Windows System Software -- Consulting, Training, Development -- Unique Expertise, Guaranteed Results

Before Posting...
Please check out the Community Guidelines in the Announcements and Administration Category.

Win10 power management issue w/ RDP

Chris_AseltineChris_Aseltine Member Posts: 1,228
I'm hitting an issue where my RDP session into a Win10 laptop will lag on mouse or keyboard input every couple of seconds, for about a half second, after the monitor is turned off (via the setting in Power control panel). It's basically the exact issue reported here:

https://social.technet.microsoft.com/Forums/windows/en-US/e90e59df-b26a-486a-a88f-52c2fee98be2/windows-10-remote-desktop-slow-delay-lag-when-laptop-screen-is-off?forum=win10itprogeneral

My questions are:

1) How would I debug that this is a real OS issue and not something I've caused? Something from Sysinternals? It's a brand new machine...

2) Is there a way to find out if this is a known MS issue, and if so, possibly obtain a hotfix? Open a support incident?

3) Can anyone think of a way to work around this? My local domain policy doesn't allow me to change the monitor timeout. I've tried disabling/reenabling keyboard and mouse from device manager to try to trigger things to wake up, but it doesn't help. Is there a way to run some sort of command line utility to make the system think it's "woken up"?

Comments

  • Eric_WittmayerEric_Wittmayer Member Posts: 13
    This list really isn't the right place for this question but i was intrigued enough to read the technet article. Sounds like the original issue was the system was going to connected standby.

    Have you tried disabling connected standby as suggested in the technet post?

    If that isn't working i would investigate what the processors are doing using windows performance analyzer or something similar. in your RDP session open up WPA and have it show the processor frequency, C State information. Here is an article with some more information. https://docs.microsoft.com/en-us/windows-hardware/test/wpt/cpu-analysis

    Also, as a quick test, try changing your power plan setting to "High Performance" They hide that choice in a collapsed section when you go into choose a power plan. It should force the system to keep the processor running at full speed all the time. If that fixes the problem then you know the issue is caused by some power management related settings.

    Hope that helps.
    Eric
  • Chris_AseltineChris_Aseltine Member Posts: 1,228
    Eric Wittmayer wrote:

    > Have you tried disabling connected standby as suggested in
    > the technet post?

    Yes, it didn't make a difference.

    > Also, as a quick test, try changing your power plan setting to
    > "High Performance" They hide that choice in a collapsed section
    > when you go into choose a power plan. It should force the system
    > to keep the processor running at full speed all the time.

    Already did that. Didn't make a difference either. The bug isn't with processor speed, it happens as soon as the monitor timeout occurs, which I have no control over.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!