Windows System Software -- Consulting, Training, Development -- Unique Expertise, Guaranteed Results

Before Posting...
Please check out the Community Guidelines in the Announcements and Administration Category.

Device not started: Device has problem: 0x0a: CM_PROB_FAILED_START

OSR_Community_UserOSR_Community_User Member Posts: 110,217
I am trying to figure out why I am getting the above message in the install log with the device NOT starting....

From the log:
[2010/11/03 12:37:04 324.348]
#-198 Command line processed: "C:\WINDOWS\system32\mmc.exe" C:\WINDOWS\system32\devmgmt.msc
#I060 Set selected driver.
#-019 Searching for hardware ID(s): usb\vid_0547&pid_1002&rev_0000,usb\vid_0547&pid_1002
#-018 Searching for compatible ID(s): usb\class_ff&subclass_00&prot_00,usb\class_ff&subclass_00,usb\class_ff
#I022 Found "USB\VID_0547&PID_1002" in C:\WINDOWS\inf\oem31.inf; Device: "WDF Sample Driver for OSR USB-FX2 Learning Kit"; Driver: "WDF Sample Driver for OSR USB-FX2 Learning Kit"; Provider: "Microsoft"; Mfg: "OSR"; Section name: "osrusbfx2.Dev".
#I087 Driver node not trusted, rank changed from 0x00000001 to 0x00008001.
#I023 Actual install section: [osrusbfx2.Dev.NT]. Rank: 0x00008001. Effective driver date: 11/02/2010.
#-166 Device install function: DIF_SELECTBESTCOMPATDRV.
#I063 Selected driver installs from section [osrusbfx2.Dev] in "c:\windows\inf\oem31.inf".
#I320 Class GUID of device remains: {78A1C341-4539-11D3-B88D-00C04FAD5171}.
#I060 Set selected driver.
#I058 Selected best compatible driver.
#-124 Doing copy-only install of "USB\VID_0547&PID_1002\5&7D4C538&0&1".
#W334 Failed to verify catalog when scanning file queue. Error 1168: Element not found.
#E360 An unsigned or incorrectly signed file "c:\windows\inf\oem31.inf" for driver "WDF Sample Driver for OSR USB-FX2 Learning Kit" will be installed (Policy=Ignore). Error 1168: Element not found.
#W187 Install failed, attempting to restore original files.
#E360 An unsigned or incorrectly signed file "c:\windows\inf\oem31.inf" for driver "WDF Sample Driver for OSR USB-FX2 Learning Kit" will be installed (Policy=Ignore). Error 1168: Element not found.
#-024 Copying file "c:\osrusbfx2 driver\osrusbfx2.sys" to "C:\WINDOWS\system32\DRIVERS\osrusbfx2.sys".
#E360 An unsigned or incorrectly signed file "c:\osrusbfx2 driver\osrusbfx2.sys" for driver "WDF Sample Driver for OSR USB-FX2 Learning Kit" will be installed (Policy=Ignore). Error 1168: Element not found.
#-336 Copying file "c:\osrusbfx2 driver\WdfCoInstaller01009.dll" to "C:\WINDOWS\system32\WdfCoInstaller01009.dll" via temporary file "C:\WINDOWS\system32\SET80.tmp".
#E360 An unsigned or incorrectly signed file "c:\osrusbfx2 driver\WdfCoInstaller01009.dll" for driver "WDF Sample Driver for OSR USB-FX2 Learning Kit" will be installed (Policy=Ignore). Error 1168: Element not found.
#-166 Device install function: DIF_REGISTER_COINSTALLERS.
#I056 Coinstallers registered.
#-166 Device install function: DIF_INSTALLINTERFACES.
#-011 Installing section [osrusbfx2.Dev.NT.Interfaces] from "c:\windows\inf\oem31.inf".
#I054 Interfaces installed.
#-166 Device install function: DIF_INSTALLDEVICE.
#I123 Doing full install of "USB\VID_0547&PID_1002\5&7D4C538&0&1".
#I163 Device not started: Device has problem: 0x0a: CM_PROB_FAILED_START.
#I121 Device install of "USB\VID_0547&PID_1002\5&7D4C538&0&1" finished successfully.

I am using the standard OSRUSBFX2.inf, WdfCoInstaller01009.dll, and have modified an ARM Mass Storage Device to look like the OSR sample board, except the mass storage device is full speed


;/*++
;
;Copyright (c) Microsoft Corporation. All rights reserved.
;
; THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY
; KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
; IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A PARTICULAR
; PURPOSE.
;
;Module Name:
;
; OSRUSBFX2.INF
;
;Abstract:
; Installation inf for OSR USB-FX2 Learning Kit
;
;--*/

[Version]
Signature="$WINDOWS NT$"
Class=Sample
ClassGuid={78A1C341-4539-11d3-B88D-00C04FAD5171}
Provider=%MSFT%
DriverVer=11/02/2010,6.1.7600.16385
CatalogFile=KmdfSamples.cat


; ================= Class section =====================

[ClassInstall32]
Addreg=SampleClassReg

[SampleClassReg]
HKR,,,0,%ClassName%
HKR,,Icon,,-5


; ================= Device section =====================

[Manufacturer]
%MfgName%=Microsoft,NTx86

; For Win2K
[Microsoft]
%USB\VID_045E&PID_930A.DeviceDesc%=osrusbfx2.Dev, USB\VID_0547&PID_1002
%Switch.DeviceDesc%=Switch.Dev, {6FDE7521-1B65-48ae-B628-80BE62016026}\OsrUsbFxRawPdo

; For XP and later
[Microsoft.NTx86]
%USB\VID_045E&PID_930A.DeviceDesc%=osrusbfx2.Dev, USB\VID_0547&PID_1002
%Switch.DeviceDesc%=Switch.Dev, {6FDE7521-1B65-48ae-B628-80BE62016026}\OsrUsbFxRawPdo


[osrusbfx2.Dev.NT]
CopyFiles=osrusbfx2.Files.Ext

[Switch.Dev.NT]
;dummy section

[Switch.Dev.NT.Services]
AddService = , %SPSVCINST_ASSOCSERVICE%,

[osrusbfx2.Dev.NT.Services]
AddService = osrusbfx2, %SPSVCINST_ASSOCSERVICE%, osrusbfx2.AddService

[osrusbfx2.AddService]
DisplayName = %osrusbfx2.SvcDesc%
ServiceType = 1 ; SERVICE_KERNEL_DRIVER
StartType = 3 ; SERVICE_DEMAND_START
ErrorControl = 1 ; SERVICE_ERROR_NORMAL
ServiceBinary = %10%\System32\Drivers\osrusbfx2.sys
AddReg = osrusbfx2.AddReg
LoadOrderGroup = Base

[osrusbfx2.Files.Ext]
osrusbfx2.sys

[SourceDisksNames]
1=%Disk_Description%,,,

[SourceDisksFiles]
osrusbfx2.sys = 1

[DestinationDirs]
DefaultDestDir = 12

;-------------- WDF Coinstaller installation

[DestinationDirs]
CoInstaller_CopyFiles = 11

[osrusbfx2.Dev.NT.CoInstallers]
AddReg=CoInstaller_AddReg
CopyFiles=CoInstaller_CopyFiles

[CoInstaller_CopyFiles]
WdfCoInstaller01009.dll

[SourceDisksFiles]
WdfCoInstaller01009.dll=1 ; make sure the number matches with SourceDisksNames

[CoInstaller_AddReg]
HKR,,CoInstallers32,0x00010000, "WdfCoInstaller01009.dll,WdfCoInstaller"

[osrusbfx2.Dev.NT.Wdf]
KmdfService = osrusbfx2, osrusbfx2_wdfsect
[osrusbfx2_wdfsect]
KmdfLibraryVersion = 1.9

;---------------------------------------------------------------;

[Strings]
MSFT="Microsoft"
MfgName="OSR"
Disk_Description="OSRUSBFX2 Installation Disk"
USB\VID_045E&PID_930A.DeviceDesc="WDF Sample Driver for OSR USB-FX2 Learning Kit"
osrusbfx2.SvcDesc="WDF Sample Driver for OSR USB-FX2 Learning Kit"
ClassName = "Sample Device"
Switch.DeviceDesc = "OsrUsbFX2 RawPdo For Switch"
SPSVCINST_ASSOCSERVICE= 0x00000002



The USB properties are:
Connection Status Device connected
Current Configuration 0
Speed Low
Device Address 0
Number Of Open Pipes 0

Device Descriptor
Offset Field Size Value Description
0 bLength 1 12h
1 bDescriptorType 1 01h Device
2 bcdUSB 2 0200h USB Spec 2.0
4 bDeviceClass 1 00h Class info in Ifc Descriptors
5 bDeviceSubClass 1 00h
6 bDeviceProtocol 1 00h
7 bMaxPacketSize0 1 08h 8 bytes
8 idVendor 2 0547h Anchor Chips, Inc.
10 idProduct 2 1002h
12 bcdDevice 2 0000h 0.00
14 iManufacturer 1 01h
15 iProduct 1 02h
16 iSerialNumber 1 00h
17 bNumConfigurations 1 01h


The PnP properties are:
Description: WDF Sample Driver for OSR USB-FX2 Learning Kit
Instance Status: 01806400h DN_HAS_PROBLEM
DN_DISABLEABLE
DN_REMOVABLE
DN_NT_ENUMERATOR
DN_NT_DRIVER
Instance ID: USB\VID_0547&PID_1002\5&7D4C538&0&1
Hardware IDs: USB\Vid_0547&Pid_1002&Rev_0000
USB\Vid_0547&Pid_1002
Compatible IDs: USB\Class_ff&SubClass_00&Prot_00
USB\Class_ff&SubClass_00
USB\Class_ff
Service Name: osrusbfx2
Setup Class: Sample
Setup Class Description: Sample Device
Setup Class GUID: {78A1C341-4539-11D3-B88D-00C04FAD5171}
Software Key: {78A1C341-4539-11D3-B88D-00C04FAD5171}\0000
Manufacturer: OSR
Friendly Name:
Hardware Location: WDF SAMPLE
PDO Name: \Device\USBPDO-5

Comments

  • Tim_RobertsTim_Roberts Member - All Emails Posts: 12,854
    xxxxx@mpr.com wrote:
    > I am trying to figure out why I am getting the above message in the install log with the device NOT starting....
    > ...

    CM_PROB_FAILED_START means that your driver loaded, passed through
    DriverEntry, passed through AddDevice, and then failed during
    IRP_MN_START_DEVICE.

    Have you modified the code in the osrusbfx2 sample at all? Have you
    READ the code at all? Did you see that the function called
    "SelectInterfaces" looks for an interrupt pipe, a bulk input pipe, and a
    bulk output pipe, and if it does not find all three, it fails? I'll
    wager real dollars that's what is happening.

    You can't just blindly apply a sample driver to another kind of device
    without understanding what it is doing.

    > I am using the standard OSRUSBFX2.inf, WdfCoInstaller01009.dll, and have modified an ARM Mass Storage Device to look like the OSR sample board, except the mass storage device is full speed

    Your USB monitor shows that the device is enumerating at low speed, not
    at full speed.

    --
    Tim Roberts, xxxxx@probo.com
    Providenza & Boekelheide, Inc.

    Tim Roberts, [email protected]
    Providenza & Boekelheide, Inc.

  • Igor_SharovarIgor_Sharovar Member Posts: 614
    This error could be caused by different reasons.
    You should provide more information.
    What version OS are you using?
    You should look setupapi log file. It usually provides more details.
    Also, you should attach WinDbg and see if DriverEntry and AddDevice are called.

    Igor Sharovar
  • Tim_RobertsTim_Roberts Member - All Emails Posts: 12,854
    xxxxx@hotmail.com wrote:
    > This error could be caused by different reasons.
    > You should provide more information.
    > What version OS are you using?

    The log file format was from XP.

    > You should look setupapi log file. It usually provides more details.

    She attached it.

    > Also, you should attach WinDbg and see if DriverEntry and AddDevice are called.

    CM_PROB_FAILED_START implies that they were. See Bob K's reply here:
    http://www.osronline.com/showthread.cfm?link=188956

    --
    Tim Roberts, xxxxx@probo.com
    Providenza & Boekelheide, Inc.

    Tim Roberts, [email protected]
    Providenza & Boekelheide, Inc.

  • OSR_Community_UserOSR_Community_User Member Posts: 110,217
    Thanks Tim,

    I thought it would load without me altering the osrusbfx2 sample. I
    will work on that tonight

    - Julia Merritt



    -----Original Message-----
    From: xxxxx@lists.osr.com
    [mailto:xxxxx@lists.osr.com] On Behalf Of Tim Roberts
    Sent: Wednesday, November 03, 2010 1:51 PM
    To: Windows System Software Devs Interest List
    Subject: Re: [ntdev] Device not started: Device has problem: 0x0a:
    CM_PROB_FAILED_START

    xxxxx@mpr.com wrote:
    > I am trying to figure out why I am getting the above message in the
    install log with the device NOT starting....
    > ...

    CM_PROB_FAILED_START means that your driver loaded, passed through
    DriverEntry, passed through AddDevice, and then failed during
    IRP_MN_START_DEVICE.

    Have you modified the code in the osrusbfx2 sample at all? Have you
    READ the code at all? Did you see that the function called
    "SelectInterfaces" looks for an interrupt pipe, a bulk input pipe, and a
    bulk output pipe, and if it does not find all three, it fails? I'll
    wager real dollars that's what is happening.

    You can't just blindly apply a sample driver to another kind of device
    without understanding what it is doing.

    > I am using the standard OSRUSBFX2.inf, WdfCoInstaller01009.dll, and
    have modified an ARM Mass Storage Device to look like the OSR sample
    board, except the mass storage device is full speed

    Your USB monitor shows that the device is enumerating at low speed, not
    at full speed.

    --
    Tim Roberts, xxxxx@probo.com
    Providenza & Boekelheide, Inc.


    ---
    NTDEV is sponsored by OSR

    For our schedule of WDF, WDM, debugging and other seminars visit:
    http://www.osr.com/seminars

    To unsubscribe, visit the List Server section of OSR Online at
    http://www.osronline.com/page.cfm?name=ListServer
  • Igor_SharovarIgor_Sharovar Member Posts: 614
    >CM_PROB_FAILED_START implies that they were. See Bob K's reply here: >http://www.osronline.com/showthread.cfm?link=188956
    I got this error when my driver even didn't start. It was problem in installation.

    Igor Sharovar
  • Igor_SharovarIgor_Sharovar Member Posts: 614
    >>CM_PROB_FAILED_START implies that they were. See Bob K's reply here: >>http://www.osronline.com/showthread.cfm?link=188956
    >I got this error when my driver even didn't start. It was problem in installation.
    Sorry, it was likely CM_PROB_FAILED_LOAD. Both names look like almost the same and they confuse sometimes.

    Igor Sharovar
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Upcoming OSR Seminars
Writing WDF Drivers 25 Feb 2019 OSR Seminar Space
Developing Minifilters 8 April 2019 OSR Seminar Space